Closed Bug 1406012 Opened 3 years ago Closed 3 years ago

"Show Library Menu" highlight is hard to notice

Categories

(Firefox :: Tours, defect)

58 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1410763
Tracking Status
firefox57 --- fix-optional
firefox58 --- affected

People

(Reporter: peterbe, Unassigned)

References

Details

Attachments

(1 file)

See screenshot. When I click the blue "Show Library Menu" nothing happens. No errors or warnings in the Browser Console.

Version of Nightly: 58.0a1 (2017-10-04) (64-bit)
Radar'ing this to Fischer.
Flags: needinfo?(fliu)
Whiteboard: [photon-onboarding][triage]
(In reply to Peter Bengtsson [:peterbe] from comment #0)
> Created attachment 8915545 [details]
> Screen Shot 2017-10-05 at 6.54.51 AM.png
> 
> See screenshot. When I click the blue "Show Library Menu" nothing happens.
> No errors or warnings in the Browser Console.
> 
> Version of Nightly: 58.0a1 (2017-10-04) (64-bit)
The "Show Library Menu" button works as expected, which is to highlight the Library button on the bar first or highlight the one inside the app menu if found no one on the bar.
Looking at the screenshot attachment 8915545 [details]. The the Library button on the bar was highlighted.
However, if the window is large like in our case here, the highlight will be somehow too subtle to be noticed.

@Verdi,
How do you think of the above case, thank you.
Flags: needinfo?(mverdi)
Summary: "Show Library Menu" does nothing → "Show Library Menu" highlight is hard to notice
Yeah this is a result of cutting the extra widget part of the highlight. Another solution that would make sense here is to highlight the button AND expand the menu. But I don't think we could do that if the toolbar button was gone and we were falling back to the menu. Then we'd just want to highlight the button and not move to the submenu. I don't know if it's possible to differentiate between the two. If you could, that might make it all work. Let's discuss this at our meeting today.
Flags: needinfo?(mverdi)
We current `showHighLight` library either in toolbar or in the appMenu. There seems no existing way to highlight in toolbar and show submenu in appMenu.

To expand the library menu, we need implement new target `library` for `showMenu` and take care both in toolbar and in appMenu cases.
In summary of comment 4, the proposal in Comment 3 is not a trivial task.
To solve this issue in short term, we might revert bug 1390055 and only highlight the library menu inside of appMenu(photon menu)?


Actually, when we highlight any toolbar icons, they will have the same " highlight is hard to notice issue.
I suggest to improve the general highlight UI design for these toolbar highlight cases.
Flags: needinfo?(mverdi)
FWIW, the previous solution to this problem was to use one of the 3 animation options supported by showHighlight.
Thanks for reminding, UITour can apply effect when showHighLight
http://bedrock.readthedocs.io/en/latest/uitour.html#showhighlight-target-effect


For the toolbar icon, I saw only `wobble` effect has different animation. `zoom` only works in appMenu, and `color` seems has no effect now.

in toolbar http://g.recordit.co/tUnmhYDsof.gif

in appMenu http://g.recordit.co/W2XVCR7v6R.gif

@verdi you can try these effects at `newtab` or `about:home` via open webconsole and paste 
`Mozilla.UITour.showHighlight("library", "wobble")` in input field.
Flags: needinfo?(fliu)
(In reply to Fred Lin [:gasolin] from comment #5)
> In summary of comment 4, the proposal in Comment 3 is not a trivial task.
> To solve this issue in short term, we might revert bug 1390055 and only
> highlight the library menu inside of appMenu(photon menu)?

Jennifer's research results confirm that the highlight on the toolbar button is not noticed. I tested with wobble effect but I don't believe it will solve the issue. I'd like us to revert bug 1390055 as Fred suggests. This will make it so that we instead open the application menu and highlight the library item. I think that's the best short-term solution.
Flags: needinfo?(mverdi)
Hi Ritu,

as comment 8, is there any process we need to fill to revert bug 1390055 on v57
Flags: needinfo?(rkothari)
Hi Fred, you can file a backout bug, e.g. Bug 1401962. Please nominate a patch for beta uplift in that new bug.
Flags: needinfo?(rkothari)
Blocks: 1410763
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Whiteboard: [photon-onboarding][triage]
Duplicate of bug: 1410763
You need to log in before you can comment on or make changes to this bug.