Closed Bug 1406138 Opened 3 years ago Closed 3 years ago

Supply ScaledFont options to WebRender via FontInstancePlatformOptions

Categories

(Core :: Graphics: WebRender, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1405790
Tracking Status
firefox57 --- unaffected
firefox58 --- unaffected

People

(Reporter: lsalzman, Assigned: lsalzman)

References

(Blocks 1 open bug)

Details

(Keywords: feature, Whiteboard: [gfx-noted])

Attachments

(1 file, 1 obsolete file)

We're currently not passing in all of the necessary options from ScaledFont over to WebRender. This requires a bunch of plumbing changes on the Gecko side and the WebRender side to bridge the divide.

The biggest offender here is Fontconfig, where we have to do a large amount of pattern parsing to boil down things for WebRender on the Gecko side (in patch).

This corresponds to the following WebRender PR that accepts the options: https://github.com/servo/webrender/pull/1816
Attachment #8915704 - Flags: review?(jmuizelaar)
Fix Windows/Mac build issues.
Attachment #8915704 - Attachment is obsolete: true
Attachment #8915704 - Flags: review?(jmuizelaar)
Attachment #8915842 - Flags: review?(jmuizelaar)
Blocks: 1405790
No longer depends on: 1405790
Attachment #8915842 - Flags: review?(jmuizelaar) → review+
I moved the patch on this bug over to bug 1405790 so it can land in the same push as the rest of the WR update.
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1405790
Priority: P1 → --
Whiteboard: [wr-mvp] [gfx-noted] → [gfx-noted]
You need to log in before you can comment on or make changes to this bug.