Closed Bug 1406227 Opened 3 years ago Closed 3 years ago

Remove nsIDOMHTMLImageElement usage from comm-central

Categories

(SeaMonkey :: General, enhancement)

enhancement
Not set
normal

Tracking

(seamonkey2.55 fixed)

RESOLVED FIXED
seamonkey2.55
Tracking Status
seamonkey2.55 --- fixed

People

(Reporter: qdot, Assigned: frg)

References

Details

Attachments

(1 file)

Looks like in editor/ui/composer/content/editor.js there's a type check that should be changed to ChromeUtils.getClassName format, and a couple of includes around shell, as well as a QI in nsWindowsShellService.

As there are no code changes I'll be making that are relevant to these requirements, this work can happen before bug 1406224 lands.
Assignee: nobody → frgrahl
Status: NEW → ASSIGNED
Attachment #8918574 - Flags: review?(iann_bugzilla)
Version: unspecified → Trunk
Comment on attachment 8918574 [details] [diff] [review]
1406227-nsIDOMHTMLImageElement.patch

LGTM r=me almost a 1-2-1 port :)
Attachment #8918574 - Flags: review?(iann_bugzilla) → review+
In order to get this to apply I had to remove the Mac part of the change, I suspect that has already landed elsewhere?
(In reply to Bill Johnson from comment #3)
> In order to get this to apply I had to remove the Mac part of the change, I
> suspect that has already landed elsewhere?

By that I mean the portion that changes nsMacShellService.cpp
The mac part should have been backed out by now and the patch should apply clean. Will check it in later. Didn't have time yesterday. Sorry.
(In reply to Frank-Rainer Grahl (:frg) from comment #5)
> The mac part should have been backed out by now and the patch should apply
> clean. Will check it in later. Didn't have time yesterday. Sorry.

Not a big deal my comment was more of a heads-up to you trying to check it in if you got conflicts.
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/41fe121d8350
Replace nsIDOMHTMLImageElement with HTMLImageElement in SeaMonkey. r=IanN
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.55
Sorry, you need to count your parenthesis better. You caused an awful lot of test failures with this:
+      if (ChromeUtils.getClassName(node) === "HTMLImageElement") ||
           node instanceof Components.interfaces.nsIDOMHTMLInputElement)

and this from bug 1408191
+        (ChromeUtils.getClassName(element) === "HTMLSelectElement") ||
         element instanceof Components.interfaces.nsIDOMHTMLTextAreaElement)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Drat you are right. Sorry. I was mostly preoccupied with l10n and didn't run it much. Will fix it in a minute.
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/11c646b34545
Follow-up: Fix bustage caused by spurious parenthesis (changeset 41fe121d8350). rs=bustage-fix
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Is the editor file used in TB? I thought this was only SeaMonkey composer?
Well, not used, but the editor.js is loaded and if there is a mismatched parenthesis, then hell will break loose. I fixed it for you but you can fix bug 1408191.
Sorry, I misread, bug 1408191 is not affected, although those parenthesis are not required.
You need to log in before you can comment on or make changes to this bug.