If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Problems saving large/multiple attachments (images) from newsgroups

VERIFIED DUPLICATE of bug 145408

Status

MailNews Core
Networking: NNTP
--
major
VERIFIED DUPLICATE of bug 145408
16 years ago
9 years ago

People

(Reporter: Adam Macznik, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711 RC1

First of my problems is an observation, that when I try to "Save All"
attachments from a newsgroup posting, Mozilla seems to get the message from the
server many times. I use dialup connection. I was watching net traffic on my
connection monitor. When there were 3 images in the message, the "Save All"
process took 3x more time than downloading that message for viewing. And the
monitor was showing there were around 3x more bytes sent, so it's not the
problem that my connection was slower during image download.


Reproducible: Sometimes
Steps to Reproduce:
1.Subscribe to an image newsgroup, which has some messages with more than 1
attachment inside, possibly large ones (like over 150k in total).
2.Click on such a message to view it. Note the duration it loads.
3.Open the attachments list and from the context menu choose "Save All".
4.Wait for attachments to save, measure the duration.


Actual Results:  Saving attachments takes longer than loading a message,
probably 3 times longer when there were 3 attachments.


Expected Results:  First of all, Mozilla should use the cached message, so it
should take no time at all.
If, for any reason, message is not cached, it should be downloaded only once and
attachments extracted from that copy.


When I tried to find a workaround, I couldn't find any. There are so many
features that don't work:

1.Saving image attachments from the context menu in 3-pane works (since bug
116234 is fixed), but only for the first image I select. The second one opens
the "save as" file dialog, then the saving progress window, but there is no
progress there.
2.Sometimes the above progress window closes immediately (as if it saved the
image from memory cache), but the file is not on the disk!!!!!!! Bug 134382 may
be addressing the same issue for IMAP.
3.Opening image from attachments list or 3-pane context menu opens it in
browser, but then saving behaves like the above. Seems like bug 71193.
4.Saving images one-by-one from attachments list seems to be loading the whole
message every time. So, it works, but doesn't spare loading time.
5.Context menus in standalone don't work at all (bug 128795) and
saving images from the attachments list there acts the same.
6.Only copying the message to a local folder helps. Attachments from my smtp
mail or local folders are saved properly. But sometimes I can't get those large
news messages to save into local folder.

I think there are two bugs seen here:
A. Large news messages are not properly cached in memory or the cache is too
small. Maybe "large attachments" is a connection between all those bugs I
mention here?
B. There is a problem with reusing already loaded message to extract attachments
from it (similar to bug 108107 for offline news, bug 93208 and probably bug
46233 for IMAP).

Please look into it and try to sort things out. Using newsgroups with binaries
is a real pain now.

*** This bug has been marked as a duplicate of 145408 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.