[feature] XBL key alias

RESOLVED FIXED in Future

Status

()

P3
normal
RESOLVED FIXED
19 years ago
18 years ago

People

(Reporter: akkzilla, Assigned: hyatt)

Tracking

({helpwanted})

Trunk
Future
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: 2 days?)

(Reporter)

Description

19 years ago
It would be very useful to have a way of setting up a XUL keybinding which
resulted in another keycode or charcode being sent along as a key event (to
bubble up further) instead of the original key event.

Possible syntax:

  <key id="emacsright" control="true" key="f" sendKey="VK_Right" />
This would make control-f send a keycode of right-arrow along to any event
consumer which might be ready to consume a right-arrow.

  <key id="inputA" control="true" keyCode="VK_END" sendChar="a" />
This would make control-END send a char code of 'a' along to any event that
might be ready to consume it.

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M12

Comment 1

19 years ago
mass-moving all m12 bugs to m13

Updated

19 years ago
Priority: P3 → P1
Summary: RFE: XUL key alias → [FEATURE] RFE: XUL key alias

Updated

19 years ago
Assignee: saari → pinkerton
Status: ASSIGNED → NEW

Comment 2

19 years ago
Reassigning to pink
Status: NEW → ASSIGNED
Target Milestone: M13 → M14
m14, accepting
(Reporter)

Comment 4

19 years ago
Thinking about this more, if this is added it should also have a way to pass
through the desired state of the modifier keys.  For instance,

  <key id="inputA" control="true" keyCode="VK_END" sendChar="a"
sendModifier="shift,alt" />

or

  <key id="inputA" control="true" keyCode="VK_END" sendChar="a"
sendShift="true" sendAlt="true"/>

(with the modifiers probably defaulting to false, not to what they were in the
original key event).

Incidentally, we now have APIs for everything we expect to call via key
bindings, so this isn't blocking anyone, though it would be a cool feature.

Updated

19 years ago
Blocks: 15681

Comment 5

19 years ago
Putting on beta1 radar.
Keywords: beta1
after talking to akkana, this falls into the "nice to have" category, certainly 
not a requirement for beta1.

pushing post-beta.
Keywords: beta1
OS: Linux → All
Hardware: PC → All
Target Milestone: M14 → M15
Priority: P1 → P3
Summary: [FEATURE] RFE: XUL key alias → [feature] XUL key alias
Whiteboard: 2 days?

Comment 7

19 years ago
reassigning to hyatt per today's meeting, prime candidate for latering...
Assignee: pinkerton → hyatt
Status: ASSIGNED → NEW
(Reporter)

Comment 8

19 years ago
Agreed -- this was always a "would be nice if someone gets some free time", and
it shouldn't take priority over more important things.  Might be a good
candidate for a helpwanted keyword.
(Assignee)

Comment 9

19 years ago
*** Bug 23587 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 10

19 years ago
*** Bug 23587 has been marked as a duplicate of this bug. ***

Comment 11

19 years ago
No time left in this release, resolving as later, putting on helpwanted radar
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Keywords: helpwanted
Resolution: --- → LATER

Comment 12

19 years ago
changing title/component to XBL
Component: Event Handling → XP Toolkit/Widgets: XBL
Summary: [feature] XUL key alias → [feature] XBL key alias

Comment 13

19 years ago
reopening all latered bugs
Status: RESOLVED → REOPENED
Resolution: LATER → ---

Comment 14

19 years ago
Moving all latered bugs to M20 as ordered by project manager.  Although these 
bugs are now open, assigned and targetted, XPToolkit has no plans to 
fix/implement them in the current release cycle, if ever.
Target Milestone: M15 → M20

Comment 15

19 years ago
Mass move of all M20 bugs to M30.

Comment 16

19 years ago
Mass move of M20 bugs to M30
Target Milestone: M20 → M30

Comment 17

19 years ago
Mass-moving all M20-M30 XPToolkit bugs to Future
Target Milestone: M30 → Future
(Assignee)

Comment 18

18 years ago
Akkana implemented this using a pref.
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.