Closed Bug 1406309 Opened 3 years ago Closed 1 year ago

better handling of the clobber need when using 'mach static-analysis'

Categories

(Firefox Build System :: Source Code Analysis, defect, P2)

defect

Tracking

(firefox58 wontfix, firefox72 fixed)

RESOLVED FIXED
mozilla72
Tracking Status
firefox58 --- wontfix
firefox72 --- fixed

People

(Reporter: Sylvestre, Assigned: andi)

References

Details

Attachments

(2 files)

$ ./mach static-analysis check --check google-readability-braces-around-statements --fix dom/presentation/Presentation.cpp 

 0:00.37 /usr/bin/make -C /home/sylvestre/dev/mozilla/mozilla-central.hg/obj-x86_64-pc-linux-gnu -j4 -s -w pre-export
 0:00.38 make : on entre dans le répertoire « /home/sylvestre/dev/mozilla/mozilla-central.hg/obj-x86_64-pc-linux-gnu »
 0:00.67 Build configuration changed. Regenerating backend.
 0:00.93 Reticulating splines...
 0:20.56 Finished reading 1311 moz.build files in 8.39s
 0:20.56 Read 118 gyp files in parallel contributing 0.00s to total wall time
 0:20.56 Processed into 10526 build config descriptors in 5.26s
 0:20.56 RecursiveMake backend executed in 4.66s
 0:20.56   3143 total backend files; 2 created; 43 updated; 3098 unchanged; 0 deleted; 53 -> 1179 Makefile
 0:20.56 FasterMake backend executed in 0.63s
 0:20.56   18 total backend files; 0 created; 2 updated; 16 unchanged; 0 deleted
 0:20.56 Total wall time: 19.67s; CPU time: 16.83s; Efficiency: 86%; Untracked: 0.74s
 0:21.26 STOP!  The CLOBBER file has changed.
 0:21.26 STOP!  /home/sylvestre/dev/mozilla/mozilla-central.hg/js/src/old-configure.in has changed, and your configure is out of date.
 0:21.26 STOP!  /home/sylvestre/dev/mozilla/mozilla-central.hg/old-configure.in has changed, and your configure is out of date.
 0:21.26 Please run the build through a sanctioned build wrapper, such as
 0:21.26 Please rerun autoconf and re-configure your build directory.
 0:21.26 Please rerun autoconf and re-configure your build directory.
 0:21.26 To ignore this message, touch "/home/sylvestre/dev/mozilla/mozilla-central.hg/js/src/configure",
 0:21.26 "mach build" or client.mk.
 0:21.26 but your build might not succeed.
 0:21.26 To ignore this message, touch "/home/sylvestre/dev/mozilla/mozilla-central.hg/configure",
 0:21.26 but your build might not succeed.
 0:21.26 Makefile:71 : la recette pour la cible « CLOBBER » a échouée
 0:21.26 make: *** [CLOBBER] Erreur 1
 0:21.26 make: *** Attente des tâches non terminées....
 0:21.26 Makefile:80 : la recette pour la cible « /home/sylvestre/dev/mozilla/mozilla-central.hg/js/src/configure » a échouée
 0:21.27 make: *** [/home/sylvestre/dev/mozilla/mozilla-central.hg/js/src/configure] Erreur 1
 0:21.27 Makefile:80 : la recette pour la cible « /home/sylvestre/dev/mozilla/mozilla-central.hg/configure » a échouée
 0:21.27 make: *** [/home/sylvestre/dev/mozilla/mozilla-central.hg/configure] Erreur 1
 0:21.27 make : on quitte le répertoire « /home/sylvestre/dev/mozilla/mozilla-central.hg/obj-x86_64-pc-linux-gnu »
Error running mach:

    ['static-analyzer', 'check', '--check', 'google-readability-braces-around-statements', '--fix', 'dom/presentation/Presentation.cpp']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.

You should consider filing a bug for this issue.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

Exception: Process executed with non-0 exit code 2: [u'/usr/bin/make', u'-C', u'/home/sylvestre/dev/mozilla/mozilla-central.hg/obj-x86_64-pc-linux-gnu', u'-j4', u'-s', u'-w', u'pre-export']

  File "/home/sylvestre/dev/mozilla/mozilla-central.hg/python/mozbuild/mozbuild/mach_commands.py", line 2219, in check
    rc = self._build_export(jobs=jobs, verbose=verbose)
  File "/home/sylvestre/dev/mozilla/mozilla-central.hg/python/mozbuild/mozbuild/mach_commands.py", line 2375, in _build_export
    line_handler=None, silent=not verbose)
  File "/home/sylvestre/dev/mozilla/mozilla-central.hg/python/mozbuild/mozbuild/base.py", line 670, in _run_make
    return fn(**params)
  File "/home/sylvestre/dev/mozilla/mozilla-central.hg/python/mozbuild/mozbuild/base.py", line 725, in _run_command_in_objdir
    return self.run_process(cwd=self.topobjdir, **args)
  File "/home/sylvestre/dev/mozilla/mozilla-central.hg/python/mach/mach/mixin/process.py", line 148, in run_process
    raise Exception('Process executed with non-0 exit code %d: %s' % (status, args))

Instead of the long error message, we should try to detect that a clobber is needed and do it directly (or at least show a better error message)
Assignee: nobody → bpostelnicu
Priority: -- → P2
Product: Core → Firefox Build System
Duplicate of this bug: 1575662
Attachment #9107193 - Attachment description: Bug 1406309 - add `AUTOCLOBBER` for our static-analysis targets. r=sylvestre → Bug 1406309 - add `AUTOCLOBBER` for our static-analysis targets.
Pushed by bpostelnicu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/10992479f249
add `AUTOCLOBBER` for our static-analysis targets. r=bastien
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
You need to log in before you can comment on or make changes to this bug.