Closed Bug 1406403 Opened 2 years ago Closed 2 years ago

Have DevEdition updates with 57.0b5 work.

Categories

(Release Engineering :: Release Automation: Other, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Callek, Assigned: Callek)

References

Details

Attachments

(2 files)

Over in https://bugzilla.mozilla.org/show_bug.cgi?id=1405203 we hit some issues with en-ZA and eo locales on win32 for 57.0b5

We also hit some update verify issues with those locales in b6. In order to try and have b7 be smooth I'm proposing we take :nthomas's advice from later on in that bug to omit them from being handled by our verification automation.
Comment on attachment 8916010 [details]
Bug 1406403 - Don't create updates for eo or en-ZA for DevEd 57.0b5.

https://reviewboard.mozilla.org/r/187286/#review192302
Attachment #8916010 - Flags: review?(rail) → review+
https://hg.mozilla.org/build/tools/rev/b1437b16de6b3eefd7a5e9830b1682999ab9be8b
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1405203
From bug 1405203 comment 6: 
Even though the patch in comment 5 landed[1], we still got failures[2]. That makes me wonder if we shouldn't have:

> en-ZA  mac, linux-i686, linux-x86_64, win64, 
> eo   mac, linux-i686, linux-x86_64, win64, 

instead. If I understand the the japanese lines correctly, ja-JP-mac is for mac. Then, "en-ZA  win32" may mean: this locale only exist for win32. Reopening the bug. 

[1] https://hg.mozilla.org/build/tools/rev/b1437b16de6b
[2] https://archive.mozilla.org/pub/devedition/tinderbox-builds/mozilla-beta-win32/release-mozilla-beta_devedition_win32_update_verify-bm91-build1-build186.txt.gz
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment on attachment 8916918 [details]
Bug 1406403 - Fix eo or en-ZA for DevEd 57.0b5

https://reviewboard.mozilla.org/r/187956/#review193114

Thanks Johan, I agree with the assessment here, and if I looked closer I think I would have come to the same conclusion. The fallout of deved b7 is that we don't have partials for these locales from deved b5, which we can live with I think...
Attachment #8916918 - Flags: review?(bugspam.Callek) → review+
I agree we can live this failure. It will fail in next beta, but will disappear in the following one. I'd prefer to fix it, in case somebody else gets confused this week.

Landed on default at: https://hg.mozilla.org/build/tools/rev/64cee38f88fc19385acf63ae771b95eabea8d824
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Apologies for the misdirection on how to adjust the patcher config.
You need to log in before you can comment on or make changes to this bug.