Closed Bug 1406544 Opened 4 years ago Closed 2 years ago

cookies sent along with query suggestions request.

Categories

(Firefox :: Address Bar, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1510281
Tracking Status
firefox57 --- fix-optional

People

(Reporter: modi.konark, Unassigned)

Details

(Keywords: privacy, Whiteboard: [fxsearch])

Attachments

(1 file)

Attached image request-cookie.png
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36

Steps to reproduce:

Regular browsing, typing in queries in address bar with query suggestions on.


Actual results:

1. Search engine as Google. 
2. While typing queries in the url bar with query suggestions option on (which is the default)
3. Each keypress then sends queries to https://www.google.com/complete/search?client=firefox&q=<query> with cookie that was set on google.com




Expected results:

Calls from query suggestions, should not carry cookies.

This is not a problem in Private mode, because there is no call to query suggestions API.
Did not check for other search providers.
Component: Untriaged → Address Bar
Keywords: privacy
Whiteboard: [fxsearch]
There is a privacy/utility trade off here that needs to be acknowledged. I discussed this with product but we haven't reached a decision yet.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1510281
You need to log in before you can comment on or make changes to this bug.