Closed Bug 1406581 Opened 2 years ago Closed 2 years ago

Intermittent browser/extensions/formautofill/test/mochitest/test_basic_creditcard_autocomplete_form.html | Test timed out.

Categories

(Toolkit :: Form Autofill, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox58 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: ralin)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure, Whiteboard: [form autofill][stockwell fixed:timing])

Attachments

(1 file)

Whiteboard: [form autofill]
Ray already investigated this issue and left some comment in bug 1404281 comment 14.
Those tests seem failed to wait for the popup, the first task in the debug build: Entering test history_only_menu_checking. I'm trying to increase the waiting time to 2000ms for our identifying function, and see if the issue is still. (2000ms is the number we've been using in bc mochitest for the same purpose)
Assignee: nobody → ralin
TH result: https://treeherder.mozilla.org/#/jobs?repo=try&revision=9f97a06c537934c959dd2a9238572b3628d10a26, it looks like increasing the wait time makes the result better, at least the frequency significantly decline in comparison. However, we should avoid doing so as 2 secs idle in tests occur to be resource wasting and could be worse along with the increment of test files. AFAIK the timeout cannot be eliminated unless we can make sure the point when identifyAutofillFields() is done, before that, a workaround like bug 1373130's might worth carrying on.
Status: NEW → ASSIGNED
See Also: → 1373130
Comment on attachment 8918812 [details]
Bug 1406581 - Add a short waiting time before basic credit card autofill mochitest initialization.

Obsoleting this. Let's see if Bug 1373130 can fix the intermittent and decide whether to close it or not then. Thanks.
Attachment #8918812 - Attachment is obsolete: true
Attachment #8918812 - Flags: review?(lchang)
By looking to the reports, it seems most of failures this week are in linux64-debug headless mode (h1). Since headless mode is added recently(I guess), and I'm still unfamiliar about the differences between normal mode. If this case, I think we'll need some tweaks for headless mode. Though I think there shouldn't be distinctions as if it's a timeout issue, normal/headless mode should both failed.
One I can guess for now is that the headless mode is controlled remotely using some drivers, it's possible that the timing issue occurs if the environment hasn't fully setup. Because test_basic_creditcard_autocomplete_form.html is the only test run in https scheme and the restarting might matter in this case.
Comment on attachment 8918812 [details]
Bug 1406581 - Add a short waiting time before basic credit card autofill mochitest initialization.

https://reviewboard.mozilla.org/r/189658/#review197946

Looks good. Let's see how it works.

::: browser/extensions/formautofill/test/mochitest/test_basic_creditcard_autocomplete_form.html:92
(Diff revision 2)
>  
>  initPopupListener();
>  
>  // Form with history only.
>  add_task(async function history_only_menu_checking() {
> +  await sleep(2000);

A comment would be better.
Attachment #8918812 - Flags: review?(lchang) → review+
Comment on attachment 8918812 [details]
Bug 1406581 - Add a short waiting time before basic credit card autofill mochitest initialization.

https://reviewboard.mozilla.org/r/189658/#review197946

Thanks for jumping in and review the patch :D

Hope it will mitigate the issue (fingers crossed...)

> A comment would be better.

comment added.
Keywords: checkin-needed
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/22ccb98faa41
Add a short waiting time before basic credit card autofill mochitest initialization. r=lchang
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/22ccb98faa41
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Whiteboard: [form autofill] → [form autofill][stockwell fixed:timing]
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Hi Tiberius,

Would you mind filing another bug for the new errors? Since there was no error for over two months since 10/31, the patch of this bug did have resolved the issue and we're not going to backout that patch. Thanks.
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Flags: needinfo?(toros)
Resolution: --- → FIXED
Flags: needinfo?(toros)
Component: Form Manager → Form Autofill
You need to log in before you can comment on or make changes to this bug.