Closed Bug 14066 Opened 21 years ago Closed 21 years ago

POP is unable to receive message when using migrated prefs.js

Categories

(MailNews Core :: Networking, defect, P3, critical)

Other
Linux
defect

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: fenella, Assigned: mscott)

References

Details

Attachments

(1 file)

Linux (1999-09-15-08 M11) (1999-09-16-08 M11)
1. In a POP account, create a mail message, send it to the same POP account
2. Create another message and send it to an IMAP account
3. From the POP account, I click on New Msg.
Actual result:  No response. Exit and re-launch, the message is not displayed in
the Inbox.  The Sent folder does not show it either.
This happens on Linux, but NOT on Win_nt 4.0
Note: This does not happen on IMAP: Log on to a IMAP account, the message sent
from step 2. is received though.
Unable to test Mac because on Mac the POP server does not load message
Assignee: phil → mscott
Status: NEW → ASSIGNED
Component: Back End → Networking-Mail
Target Milestone: M11
I just sent myself a message on linux to a pop account and then downloaded the
message and saw it (also on Linux).

I'll keep trying to play around with it.
I showed it to Esther. We checked the migrated prefs.js file too.
She is going to try it on her Linux machine.
Linux (1999-09-16-08 M11)
Esther and I tried it on her Linux, using qatest04 (POP) account, the problem
is there too.
I used qatest01 (POP) account.
Is most of QA failing to get new mail for pop on linux? It still works for me.
Are you and esther using the same account (i.e. I wonder if it is a problem with
a particular account)
No.  Esther used qatest04 but I used qatest01.
The problem exists in today's build , linux (1999-09-17-08 M11)
Blocks: 11091
Severity: normal → critical
Summary: Regression: POP is unable to receive message → POP is unable to receive message when using migrated prefs.js
Here may be the reason:

POP account that used the migrated prefs.js:  I am unable to receive message
when clicking on New Msg

But when I use the same POP account using the menually edited prefs.js file, I
am able to receive message when clicking on New Msg.
fenella - pls attach the prefs file that has problems (as an attachment, don't
paste into the body of the bug report).
I'm going to try running on linux with -installer and then I'll take a look at
the prefs it generates to see if anything looks wrong.
My linux build is in bad shape. I'm kicking off a new clobber build but it won't
be done for several hours. Fenella, when you get in tomorrow, can you attach the
migrated prefs.js that don't work for you? Thanks!
Attached file Migrated prefs file
Thanks for posting the prefs Fenella. The pop server name in the prefs was
listed as: Pop.

This happens if you didn't really have a pop account set up in 4.5 when you
migrated. Can you start up 4.5x on that profile and make sure pop works over
there? (i.e. you have a valid pop host name and get new mail over there).
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → WORKSFORME
Per a hallway discussion with esther when she migrated a 4.x profile on linux
today, I'm going to mark this as worksfor me. Feel free to re-open later if you
disagree.
Status: RESOLVED → VERIFIED
Linux (1999-10-18-08  M11)
Agree. Now that my migrated 4.x prefs shows the POP server is: nsmail-2
The problem no longer exists.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.