Closed Bug 1406744 Opened 2 years ago Closed 2 years ago

Opening two tabs with the same URL when browser.tabs.loadBookmarksInTabs is set to true.

Categories

(Firefox :: Bookmarks & History, defect, P3)

57 Branch
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox57 - wontfix
firefox58 --- wontfix
firefox59 --- fixed

People

(Reporter: rockridge07, Unassigned)

References

Details

(Whiteboard: [reserve-photon-structure])

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20171007220156

Steps to reproduce:

1. Make sure that browser.tabs.loadBookmarksInTabs is set to true.
2. Open the hamburger menu and click Library then Bookmarks. 
3. Click any one of the Recently Bookmarked items.


Actual results:

Firefox opens two tabs with the same URL.



Expected results:

Firefox opens just one tab.

It's OK if you use the Library button on the toolbar. The Bookmarks Menu button also works well.
Blocks: 658245
Status: UNCONFIRMED → NEW
Has STR: --- → yes
Component: Untriaged → Bookmarks & History
Ever confirmed: true
Version: 58 Branch → 57 Branch
Whiteboard: [photon-structure][triage]
seems like a minor issue with non-default config, doesn't feel worth tracking.
Priority: -- → P4
Whiteboard: [photon-structure][triage] → [reserve-photon-structure]
Is this still valid in the current version?
Flags: needinfo?(rockridge07)
Priority: P4 → P3
I just tried this on Mac and it wfm on current nightly (FF 60 builds)
It now works for me on Linux Nightly.
(In reply to Marco Bonardo [::mak] from comment #2)
> Is this still valid in the current version?

No. Windows Nightly 60 works for me.
Plus, Firefox 59.0b3 works for me, too.
But Firefox 58.0 on Release channel has the same problem.

It appears this bug was fixed at some time in Nightly 59 cycle.
Cool, thanks.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(rockridge07)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.