Ts time increase with this checkin

RESOLVED INVALID

Status

SeaMonkey
General
P1
critical
RESOLVED INVALID
16 years ago
14 years ago

People

(Reporter: Chris McAfee, Assigned: Darin Fisher)

Tracking

({perf, regression})

Trunk
x86
All
perf, regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [RTM])

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
This checkin from darin increased startup times on the
non-comet builds by 1% or so, this is a reminder to check
this out on Monday and make sure this time penalty is Ok.

http://bonsai.mozilla.org/cvsquery.cgi?module=MozillaTinderboxAll&branch=HEAD&cvsroot=/cvsroot&date=explicit&mindate=1019885220&maxdate=1019885820&who=darin%25netscape.com
(Reporter)

Updated

16 years ago
Keywords: perf, regression
(Assignee)

Updated

16 years ago
Severity: normal → critical
Status: NEW → ASSIGNED
Keywords: mozilla1.0
Priority: -- → P1
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 1

16 years ago
ok, so i spent some time hacking on sleestack to see if i couldn't come up with
the solution to this regression.  i discovered the cause of at least half of the
problem, and i'm working on a fix now.

i have some ideas about what might be causing the other half of the Ts regression.
i'll try to investigate that tomorrow.
(Assignee)

Comment 2

16 years ago
Created attachment 81880 [details] [diff] [review]
preliminary patch (shaves off part of the Ts perf loss)

still needs more work
(Assignee)

Comment 3

16 years ago
Created attachment 81949 [details] [diff] [review]
preliminary patch (other helpful changes)
(Assignee)

Comment 4

16 years ago
i'm working on a solution for this post-1.0
Whiteboard: [RTM]
Target Milestone: mozilla1.0 → mozilla1.0.1
(Assignee)

Comment 5

16 years ago
Created attachment 82168 [details] [diff] [review]
yet another preliminary patch of goodies
(Assignee)

Updated

16 years ago
Target Milestone: mozilla1.0.1 → ---
(Assignee)

Comment 6

16 years ago
ok, all of these patches are obsolete now.  in another bug i reverted all of the
startup code to use the native versions of the nsIFile methods.  hence, there's
no more work to do here.

marking INVALID.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.