[Photon] Unable to drag tab to [Bookmark Toolbar Items] while it is located in the navbar

VERIFIED FIXED in Firefox 57

Status

()

defect
P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: zombie, Assigned: jaws)

Tracking

({regression})

unspecified
Firefox 58
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox56 unaffected, firefox57 verified, firefox58 verified)

Details

(Whiteboard: [reserve-photon-structure])

Attachments

(1 attachment)

This is broken since 57, worked in 56.  

Dragging a tab into the same bookmark thingie while in the bookmark toolbar still works.

Windows 7, regardless of theme.
Hi Gijs, I'm guessing you would like to know about this.
Flags: needinfo?(gijskruitbosch+bugs)
Can you find a more precise regression window?
Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(tomica)
Whiteboard: [photon-structure][triage]
Maybe this was caused by bug 450915...
Flags: needinfo?(jaws)
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Flags: needinfo?(jaws)
Priority: -- → P1
Whiteboard: [photon-structure][triage] → [reserve-photon-structure]
Comment on attachment 8916636 [details]
Bug 1406770 - Allow dropping tabs on to the Bookmarks Toolbar Item if it is located in the nav-bar.

https://reviewboard.mozilla.org/r/187744/#review192788
Attachment #8916636 - Flags: review?(gijskruitbosch+bugs) → review+
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e45c439aac94
Allow dropping tabs on to the Bookmarks Toolbar Item if it is located in the nav-bar. r=Gijs
Comment on attachment 8916636 [details]
Bug 1406770 - Allow dropping tabs on to the Bookmarks Toolbar Item if it is located in the nav-bar.

Approval Request Comment
[Feature/Bug causing the regression]: bug 450915
[User impact if declined]: bookmarking in some situations will appear broken
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: this patch just adds an extra case to the list of allowed drop targets. this list has been present and used since bug 450915 landed.
[String changes made/needed]: none
Attachment #8916636 - Flags: approval-mozilla-beta?
Comment on attachment 8916636 [details]
Bug 1406770 - Allow dropping tabs on to the Bookmarks Toolbar Item if it is located in the nav-bar.

Photon related, beta57+
Attachment #8916636 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
https://hg.mozilla.org/mozilla-central/rev/e45c439aac94
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Verified fixed using the latest Nightly (2017-10-10) and Firefox Beta 57.0b7 on Windows 10 x64, Windows 7 x86, Ubuntu 16.04 x64 and Mac OS X 10.13
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.