Status

RESOLVED FIXED
17 years ago
14 years ago

People

(Reporter: arperez, Assigned: mkaply)

Tracking

Trunk
Other
OS/2

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

17 years ago
My system is setup for 1024 x 768 256 colors .
Mozilla browser displays the Web page as 1024 x 768 16 colors.
I test it by loading Netscape ver 4.61 for OS/2 and loading the same Web page
with both browsers and Mozilla Ver 
Mozilla 0.9.9+
Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:0.9.9+) Gecko/20020426
and Mozilla always displayed the page in 16 colors.
Thanks
(Assignee)

Comment 1

17 years ago
This probably won't make Mozilla 1.0.

We have very few users using 256 colors.
Assignee: Matti → mkaply
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: colors not displayed correctly → No 256 color support

Comment 2

16 years ago
This looks like a dupe of 88560:

Major jpeg display/dithering problem on NT w/ 256 colors.
http://bugzilla.mozilla.org/show_bug.cgi?id=88560
(Assignee)

Comment 3

16 years ago
OS/2 will require custom code for this separate from the Windows code
(Assignee)

Comment 4

16 years ago
*** Bug 95167 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

16 years ago
Created attachment 110824 [details] [diff] [review]
256 color support

First pass at 256 color.

Only outstanding problem is that entryfields are missing their lower right
lines.

Working.
(Assignee)

Comment 6

16 years ago
Created attachment 111408 [details] [diff] [review]
Final patch

Note this slows down the browser considerably.

Welcome to 256 color.
Attachment #110824 - Attachment is obsolete: true
(Assignee)

Updated

16 years ago
Attachment #111408 - Flags: review?(pedemont)
Comment on attachment 111408 [details] [diff] [review]
Final patch

> +  mIsPaletteDevice = !!(alArray[CAPS_ADDITIONAL_GRAPHICS] & CAPS_PALETTE_MANAGER);
Don't like this syntax.  I think it would be much clearer if you explicitly
checked to see if it was equal to a given value (i.e. "a & b == 0x001").

Otherwise, r=pedemont
Attachment #111408 - Flags: review?(pedemont) → review+

Comment 8

16 years ago
I disagree.  If you see the 0x0001, then you have no idea what it means.  Here I
know what exactly he is testing.  But it is ugly.  Maybe a nice comment above
the line?  Notnot'ing is icky!
(Assignee)

Comment 9

16 years ago
Fixed. We're slow but pretty.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.