Closed Bug 1406994 Opened 2 years ago Closed 2 years ago

Search toolbar not shown in gloda tab

Categories

(Thunderbird :: Search, defect)

defect
Not set

Tracking

(thunderbird57 fixed, thunderbird58 fixed)

RESOLVED FIXED
Thunderbird 58.0
Tracking Status
thunderbird57 --- fixed
thunderbird58 --- fixed

People

(Reporter: Paenglab, Assigned: Paenglab)

References

Details

(Keywords: regression)

Attachments

(1 file)

Bug 1394269 fixed showing the border below the tab in Downloads tab. But unfortunately it hides the toolbar in gloda tab too.
It was not so easy to spot the needed rules because DOMi doesn't work and I have to use the DevTools Inspector which isn't very well-arranged. This works now for the Add-on manager, in-content prefs, Download manager and the gloda tab. Do we have other tabs types (Lightning and messages in tabs aren't affected)?

I'm asking for uplift because bug 1394269 is in 57.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8916693 - Flags: review?(jorgk)
Attachment #8916693 - Flags: approval-comm-beta?
Comment on attachment 8916693 [details] [diff] [review]
contentTabToolbox.patch

(In reply to Richard Marti (:Paenglab) from comment #0)
> Bug 1394269 fixed showing the border below the tab in Downloads tab. But
> unfortunately it hides the toolbar in gloda tab too.
Damn, I was annoyed with Gloda lately since I always had to return to the main tab to be able to search again. Now I realise what was missing :-(

(In reply to Richard Marti (:Paenglab) from comment #1)
> This works now for the Add-on manager, in-content prefs, Download
> manager and the gloda tab.
Not sure what you're saying here. Only Gloda was negatively affected, no?

P.S.: See that CSS changes can break things ;-)
Attachment #8916693 - Flags: review?(jorgk)
Attachment #8916693 - Flags: review+
Attachment #8916693 - Flags: approval-comm-beta?
Attachment #8916693 - Flags: approval-comm-beta+
Keywords: checkin-needed
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/c6b2df26fba5
Show the .contentTabToolbox in Gloda search. r=jorgk
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 58.0
You need to log in before you can comment on or make changes to this bug.