Wrong information and incorrect update of information in the "file download progress" window for IMAP server non-inline attachments

VERIFIED DUPLICATE of bug 135384

Status

VERIFIED DUPLICATE of bug 135384
17 years ago
11 years ago

People

(Reporter: hbd, Assigned: mscott)

Tracking

Trunk
x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

When saving a non-inline attachment of the 
message located on an IMAP server with
double-clicking on the element of the attachment list
and choosing "save as", a 
"file download progress window" appears
that shows wrong information and is updated
incorrectly and not in time.


Reproducible: Always
Steps to Reproduce:
[assuming you have an IMAP mail account]
1. Open the Mozilla mail frontend
2. Send yourself a message with non-inline attachment(s)
3. Click on the new message's title in the Inbox
4. Double-click on an element of the attachment list, choose "save as"
5. In the "save as" dialog, choose the file name and click "OK"
6. Look at the "file download progress" window that appears

Actual Results:  In the "file download progress" window, 
the "elapsed time" indicator, the
progress bar and the "% saved" field in the window's header
are not updated continuously, but are instead updated 
three times:
1. After opening the window (no progress bar at all, 
  no "%saved" field, something like "elapsed time 4 secs")

2. Some time later (progress bar is 100% and contains moving 
  stripes, "-1% saved" in the header -- a nonsense,
  and elapsed time is, say, 24 secs)

3. In the end (progress bar is 100% and is solid, "100%saved"
  in the header, and elapsed time is the total time of the 
  operation)


Expected Results:  The "File download progress" window should be 
updated continuously, showing the increasion 
of elapsed time, and the percentage of completion both
in the window's header and in the progress bar.
The progress bar should grow according to the progress.
Nothing like "-1% saved" should be shown,
better to start from "0% saved".

This is the problem _not_ related to the mail server,
since when I save the attachment with right click + "save as",
the "downloading message" progress bar in the status line 
of the mail front-end shows the real progress of the downloading
of the attached file (not the whole message, I tried that on 
the message with several attachments, and looks like only the 
selected one is loaded, since is loads quickly).

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 135384 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
changing qa contact to yulian
QA Contact: trix → yulian
QA Contact: yulian → stephend
verified dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.