Closed Bug 1407207 Opened 3 years ago Closed 3 years ago

9.15 - 9.81% build times (windows2012-32, windows2012-64) regression on push dbcd58f04e4fc7d5172fffb7cad19d9d2a6d957b (Mon Oct 9 2017)

Categories

(Core :: DOM: Core & HTML, defect, P1)

Unspecified
Windows
defect

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox-esr52 --- unaffected
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- fixed

People

(Reporter: igoldan, Assigned: farre)

References

Details

(Keywords: regression)

Attachments

(1 file)

We have detected a build metrics regression from push:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=dbcd58f04e4fc7d5172fffb7cad19d9d2a6d957b

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

 10%  build times summary windows2012-32 pgo taskcluster-c4.4xlarge     4,923.61 -> 5,406.69
  9%  build times summary windows2012-64 pgo taskcluster-c4.4xlarge     5,268.43 -> 5,750.40


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=9906

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Automated_Performance_Testing_and_Sheriffing/Build_Metrics
Component: Untriaged → DOM
Product: Firefox → Core
:farre I see that the change in bug 1377766 increased the build time for Windows PGOs. The OPT build times don't seem affected.
Is this just a build process issue or can we do something about it?
Flags: needinfo?(afarre)
I see that build/pgo/index.html uses setTimeout. This could be the cause, not sure what to do about it though. Looking some more.
Assignee: nobody → afarre
Flags: needinfo?(afarre)
Priority: -- → P1
Trouble was that the instrumented build is slow, which means timeouts get punished harder than for a release build. This is kind of silly for pgo profiling, so the solution is to disable budget throttling for generating the pgo profile.
Attachment #8917375 - Flags: feedback?(ted) → feedback+
Attachment #8917375 - Flags: review?(ted) → review+
Pushed by afarre@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b0b797668d26
Make it possible to turn off budget throttling for pgo. r=ted
I see some improvements:
== Change summary for alert #9979 (as of October 12 2017 13:21 UTC) ==

Improvements:

  8%  build times summary windows2012-64 pgo taskcluster-c4.4xlarge     5,745.15 -> 5,294.00
  8%  build times summary windows2012-32 pgo taskcluster-c4.4xlarge     5,518.82 -> 5,096.00

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=9979
https://hg.mozilla.org/mozilla-central/rev/b0b797668d26
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
"PERF" key word?
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.