Closed Bug 1407234 Opened 3 years ago Closed 3 years ago

Invalid client id type in preferences with a new profile

Categories

(Toolkit :: Telemetry, defect, P1)

defect
Points:
1

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox56 --- wontfix
firefox57 --- wontfix
firefox58 --- fixed

People

(Reporter: aflorinescu, Assigned: Dexter)

References

Details

Attachments

(1 file)

[Environment:]
56.0   20170926190823
57.0b6 20171005195903
58.0a1 20171009100134

Ubuntu 16.04x64, Windows 10x64, MacOsX10.12


[Steps:]
1. Open Firefox 56 with a new profile. (this happens first time startup on new profile only)
2. Open browser console.
3(optional). I've also enabled telemetry trace log and shield log level 0 before first run.


[Actual Result:]
https://pastebin.mozilla.org/9069627

line 9. 1507633826442   Toolkit.Telemetry  ERROR     ClientID::getCachedClientID - invalid client id type in preferences, resetting  Log.jsm:752


After restart, I don't see this error anymore.

[Note1:]
Not sure what these errors mean, but I would like to make sure there are not connected or dependent of the bug 1406532, before moving this issue to a better component.

[Note2:]
Is this a dupe after bug 1218746 or rather a regression?
(In reply to Adrian Florinescu [:AdrianSV] from comment #0)
> [Note2:]
> Is this a dupe after bug 1218746 or rather a regression?

Thanks Adrian! This looks like a regression, possibly from 1357517.

Just to make sure the SHIELD experiment isn't interfering, would you mind checking if this is happening on a new profile without any shield experiment (it should!)?
Points: --- → 1
Flags: needinfo?(adrian.florinescu)
Priority: -- → P2
I've created a new profile, setting the prefs.js with user_pref("extensions.shield-recipe-client.enabled",false); on the first run startup comment 0 reproduced, so I guess it's safe to assume that no Shield experiment got in the way.
Flags: needinfo?(adrian.florinescu)
Assignee: nobody → alessio.placitelli
Priority: P2 → P1
Comment on attachment 8917357 [details]
Bug 1407234 - Don't show getCachedClientID error on new profiles.

https://reviewboard.mozilla.org/r/188362/#review193616
Attachment #8917357 - Flags: review?(chutten) → review+
Pushed by alessio.placitelli@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/4b4228043dd8
Don't show getCachedClientID error on new profiles. r=chutten
https://hg.mozilla.org/mozilla-central/rev/4b4228043dd8
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Calling this wontfix for 57, please reset back to affected and request uplift if you disagree.
You need to log in before you can comment on or make changes to this bug.