Closed Bug 1407263 Opened 2 years ago Closed 2 years ago

Sections are no longer animated when collapsed if the sections were disabled and re-enabled from customization menu

Categories

(Firefox :: New Tab Page, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 58
Tracking Status
firefox57 --- wontfix
firefox58 --- verified

People

(Reporter: cmuresan, Assigned: ursula)

References

Details

Attachments

(1 file)

[Affected versions]:
- Firefox 58.0a1 Build ID 20171009220104

[Affected Platforms]:
- All Windows
- All Mac
- All Linux

[Steps to reproduce]:
1. Start the browser with the profile from prerequisites and open a New Tab.
2. Disable and re-enable the Top Sites section.
3. Click the Top Sites text and observe the behavior.

[Expected results]:
- The Top Sites section is animated as it is collapsed.

[Actual results]:
- The Top Sites section is no longer animated when collapsed.

[Notes]:
- The issue is also reproducible for the "Recommended by Pocket" and "Highlights" sections.
- The issue is no longer reproducible after refreshing the page.
- Attached a screen recording of the issue.
Fixed with https://github.com/mozilla/activity-stream/pull/3718 to be uplifted via bug 1410541.
Assignee: nobody → usarracini
Blocks: 1410541
https://hg.mozilla.org/mozilla-central/rev/d1f0c44b2d79
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
I have verified that the issue is no longer reproducible on Windows 10 x64, Ubuntu 14.04 x64 and Mac 10.12 using Nightly 58.0a1 Build ID 20171026221945.
Status: RESOLVED → VERIFIED
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.