Closed Bug 1407291 Opened 3 years ago Closed 3 years ago

Title in titlebar shown with tabs in titlebar

Categories

(Thunderbird :: Mail Window Front End, enhancement)

All
macOS
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 58.0

People

(Reporter: Paenglab, Assigned: Paenglab)

References

Details

Attachments

(1 file)

Since some days the title is shown in titlbar also when we draw the tabs in the titlebar. Thia makes reading the tab title hard when it's where the titlebar title is placed.
In browser's browser-tabsintitlebar.js the "drawtitle" attribute is set or removed. We don't have done this, and now the titlebar title is always shown.

I copied as much as possible from browser-tabsintitlebar.js to msgMail3PaneWindow.js. This includes the shortening of the function how it's possible with ES6 now.

As much as possible, because we still can hide the tabbar when we have only one tab. When this is enabled, we don't enable draw in titlebar.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8917040 - Flags: review?(jorgk)
Comment on attachment 8917040 [details] [diff] [review]
msgMail3PaneWindow.patch

I've tried it on Windows 7 compared the code in browser-tabsintitlebar.js.
Attachment #8917040 - Flags: review?(jorgk) → review+
Keywords: checkin-needed
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/1eba18865abe
Port browser-tabsintitlebar.js changes to TB (add "drawtitle" for macOS and shorten in TabsInTitlebar var the functions to ES6 notation). r=jorgk
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 58.0
Duplicate of this bug: 1416547
Can we backport this to 57 in case we are doing a further beta?
Actually, forget that, 58 is already here anyway :)
I'd like that. Isn't 58 beta only coming out in ~6 weeks?
Duplicate of this bug: 1419163
Duplicate of this bug: 1420280
Are the comments above suggesting that this is fixed for 58? - so is version 58 usable

Pity no image of the bug - i sent one, in 1420280 report, so take it someone looked at it to decide a dupe of this one

antony
ok just d/l 58 and installed, overlay fixed, in case you wanted some test pilot :-)
(In reply to Albert Scheiner [:alberts] from comment #7)
> I'd like that. Isn't 58 beta only coming out in ~6 weeks?

Albert - pulled off via ftp /pub/thunderbird/candidates/58.0b1-candidates/build2/mac/ 

Installed and works fine.. so far! No overlay of tab name on main bar now - lightning still works fine still as well
You need to log in before you can comment on or make changes to this bug.