Open Bug 1407312 Opened 4 years ago Updated 3 years ago

"search for text when you start typing" feature is missing characters from Barcode Scanner

Categories

(Core :: Find Backend, defect, P3)

56 Branch
defect

Tracking

()

People

(Reporter: johnmaverick74, Unassigned)

References

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170926190823

Steps to reproduce:

Plug in and configure a Barcode scanner
Read a Barcode with a (perfectly functional and well configured!) Scanner with the feature "search for text when you start typing" set to ON in order to search the code on the page i'm at


Actual results:

Biggest part of the code is missing (however, very rarely, it does read the complete code)


Expected results:

Firefox's find bar should came up and always search for the complete barcode as soon as the scanner reads the code
I would like to add that i did try different Barcode Scanners all which were previously working just fine (with FindBar Tweak addon, however...)

This happens on Windows 10 pro 64Bit (Creators Update) and with OpenSuse Tumbleweed and Leap 42.3 (both 64bit)

Also tested it on FF57 beta and FF58 alpha (both 64bit also).
one extra weird thing i forgot to add that may be relevant: Occasionally it also reads the complete code but alters the chars order...
Please contact the extension author to get help. Thank you!
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
(In reply to Kohei Yoshino [:kohei] from comment #3)
> Please contact the extension author to get help. Thank you!

The bug has nothing to do with the addon!!! Any Firefox without any Addons is doing this to me! Please read what i've wrote correctly
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Hi John,
Can you please upload a video attachment with your steps to reproduce this bug? 
Because I can't reproduce this issue.
Flags: needinfo?(johnmaverick74)
Flags: needinfo?(johnmaverick74)
Hi Valentina,

I've uploaded a video as you requested.

I'm always Scanning the same Barcode ( SL17284013 ).

If i scan it anywhere else (on other programs or even elsewhere on firefox)  it works perfectly. Also, if i press Ctrl+F before i scan the code - to get the search field selected - it also scans well.

but using the option "Search for Text when i start typing" i always get this behavior. I've tried different scanners and different OS's. Always get this weird result. If you look at 0:22 sec you'll see that it even mixes the letters searching for S17284013L instead of SL17284013...
Component: Untriaged → Find Backend
Product: Firefox → Core
The funny thing is: IF you install the (soon-to-be-dead) Findbar tweak addon and set it to do the same (search for text when you start typing) it works fine!

Now either the addon is not using Firefox's find backend or the developer ( @Quicksaver ) found a way to fix the bug
Hi John, it may very well be that the Findbar Tweak addon is working around issues like this. What might be the case here is that the barcode scanner dynamically updates the contents of the document, but the findbar doesn't reset when the document changed.

Perhaps Luís Miguel (Quiksaver) may be able to tell us more and perhaps even explain why the behavior us different with his addon enabled?
Flags: needinfo?(quicksaver)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
(In reply to Mike de Boer [:mikedeboer] from comment #9)
> Hi John, it may very well be that the Findbar Tweak addon is working around
> issues like this. What might be the case here is that the barcode scanner
> dynamically updates the contents of the document, but the findbar doesn't
> reset when the document changed.
> 
> Perhaps Luís Miguel (Quiksaver) may be able to tell us more and perhaps even
> explain why the behavior us different with his addon enabled?

Hi Mike,

Thanks for reply. This is a very important issue for us, at my workplace. We rely heavily on this feature, since we use the scanner to read dezens (sometimes hundreds) of documents.

Problem is that, now, findbar tweak stopped working as well. It's probably my fault in trying to find the cause and messing around. But the fact is that findbar tweak is now behaving just like the native find function.

I've got to get to the bottom of this before 57 is out or i'll have a few coworkers all over me...

(i'll try to get in touch with Luis... hope he'll give us a hand, considering he switched to Vivaldi these days...)

I'll also try to find out any other clues. If you see anything else i can do to help, please just say so (i have limited coding skills, however...)
(In reply to Mike de Boer [:mikedeboer] from comment #9)
> What might be the case here is that the barcode scanner
> dynamically updates the contents of the document, but the findbar doesn't
> reset when the document changed.

About this line, i might not be understanding you right... but if i am, i can say that the document (webpage) was not changed by the scanner (as seen in the video). But, again, maybe i'm not understanding what your trying to say...
OK, in which case the failure is strange. Can you attach a sample HTML document that you saved with which you can reproduce this issue? With that I can try to reproduce it locally as well.
Flags: needinfo?(quicksaver) → needinfo?(johnmaverick74)
The HTML Document used in the video
Flags: needinfo?(johnmaverick74)
Sure. 

This was the actual document i created and used with the video.

by the way, one of the workstations we have had to be formatted so i used it to clear any chances of being Findbar tweak  altering the Firefox native behavior.

in a clean 64bit machine, with a 64bit Firefox and without ever having FindBar Tweak addon installed on the system, the result was the same... (the only addons installed were: Ublock origin, Shortkeys, Firefox Pioneer and Mozilla's Safe Browsing Version 4 (temporary add-on) )
Mike, There's another thing i didn't mention that might be worth sharing: I'm using Firefox's pt-pt language version...
Is there any news in this?
No, as in: I can't seem to reproduce this _at all_ locally. Are you able to reproduce this on any computer you try this on?
Preferably without _any_ addon installed/ enabled.
Flags: needinfo?(johnmaverick74)
Unfortunately, yes!!! In every computer i try it (either with addons or without them), it behaves the same.

I've tried on
- a computer that was "completely formated" (imagine an fdisk) and so in a clean Firefox install _without any addons_

I tried on Firefox that had addons installed by
- starting it in Safe mode 
- Refreshing Firefox (with a new profile)

- I tried the latest beta of firefox 57.

- I also tried with different scanner brands.

I always get the same result.

It's worth noting that beside Firefox being in pt_pt, its the 64bit version (as, now, almost all of our machines are in 64bit)

(_and this made me think about another detail i have to check and report back to you - it's a long shot, but as of now, anything goes - will see how it behaves on a 32bit_)

Anyway, if you think of any other way to test this, to help you figure it out, or to prove i'm not making this up, please say so.

Changing browsers in all this machines is not a good solution, but we cannot function with this bug either...
Flags: needinfo?(johnmaverick74)
Ok, i took the time and went on to another building just to try this on a 32bit machine. 

In it there is no problem!!! Firefox receives the readings correctly!!!

In this machine, however, i had the _findbar tweak_ addon installed and in this machine i cannot make a Firefox refresh - it's a very important production machine!!!

i was able to disable the addon, however, and test the readings with findbar tweak _disabled_ and with just the "search for text when you start typing" enabled.

it works as it should. No reading errors.

based on this results, i installed Firefox 32bit on a 64bit machine and i can confirm that it does not work

So:

Firefox 32bit (on a 32bit machine) - Works OK
Firefox 32bit (on a 64bit machine) - Does NOT Work
Firefox 64bit (on a 64bit machine) - Does NOT Work
I should add that this is also not Windows related, as i'm on OpenSuse and have the same problem.

Also, this did not happen before, at least on Linux (i think - but i'm not sure - that Firefox 55 worked ok. At least 54, _for sure_ was OK)
(In reply to Mike de Boer [:mikedeboer] from comment #17)
> No, as in: I can't seem to reproduce this _at all_ locally. Are you able to
> reproduce this on any computer you try this on?
> Preferably without _any_ addon installed/ enabled.

What else can I do? How can i help?

( We have at least 15 machines with this problem confirmed! Have you been able to reproduce this already? )
Next Friday (November 17th) I'll be formatting our last 32bit machine and installing a 64bit OS.

If you think there are some tests worth doing before || after that that might help solving this bug, please say so.
An additional information: I recently notice that IF the user does not let the search bar get hidden (which happens after more or less 5 sec) and keeps reading codes, the scanner reads them correctly. However if we let the stipulated time pass (or press Esc) and the search bar get hidden it will not get the complete code (as shown on the movie)!
Recent versions of Firefox 58+ are considerable better (they don't fail as much as they used to!).

Still, we noticed a new bug that might be related to this one: https://bugzilla.mozilla.org/show_bug.cgi?id=1436431
One additional detail: all codes have a Start and Stop Character - an *
See Also: → 1436431

Since it seems to be only i that is experiencing this, it's probably a local problem of somekind...

In order to keep bugzilla cleaner i think we can close it and if i figure out something else about this I'll post or ask to reopen.

You need to log in before you can comment on or make changes to this bug.