Closed Bug 1407345 Opened 4 years ago Closed 3 years ago

Not disabling subpixel AA for text that's rendered to an intermediate surface due to a sibling with mix-blend-mode

Categories

(Core :: Graphics: WebRender, defect, P3)

defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox57 --- unaffected
firefox58 --- unaffected

People

(Reporter: mstange, Assigned: lsalzman)

References

Details

(Keywords: regression, Whiteboard: [wr-reserve])

Attachments

(1 file, 1 obsolete file)

Attached file testcase (obsolete) —
In this testcase, the text "Test test" in the second line has black boxes around it.
Whiteboard: [wr-mvp] [triage]
Whiteboard: [wr-mvp] [triage] → [wr-reserve]
(In reply to Markus Stange [:mstange] from comment #0)
> Created attachment 8917075 [details]
> testcase
> 
> In this testcase, the text "Test test" in the second line has black boxes around it.

layers.acceleration.force-enabled, gfx.webrender.enabled, gfx.webrendest.enabled

(I learned from a first run that 2017-10-10 was fine.)
mozregression --good 2017-10-10 --bad 2017-10-08 --profile-persistence clone-first --find-fix
> 7:49.64 INFO: First good revision: 20fa8f7c5cac22579e5acb0a295d127b43ac5c3a
> 7:49.64 INFO: Last bad revision: 6bec02f9a646f11777dbc12ceeb90af76198242d
> 7:49.64 INFO: Pushlog:
> https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=6bec02f9a646f11777dbc12ceeb90af76198242d&tochange=20fa8f7c5cac22579e5acb0a295d127b43ac5c3a

This got fixed by bug 1405790 (2017-10-10).
You're right, the black boxes are gone (due to https://github.com/servo/webrender/pull/1965 ), but they were only a symptom of the real problem that I filed this bug about: We're not disabling subpixel AA for text in some cases when we should.

I'm going to attach a different testcase that shows what's going wrong when that happens.
Summary: Black squares around text when mix-blend-mode is involved, sometimes → Not disabling subpixel AA for text that's rendered to an intermediate surface due to a sibling with mix-blend-mode
Attached file testcase
The "Test test" text has bad color fringing because it's using subpixel AA blending into transparency. It should be using grayscale AA.
Attachment #8917075 - Attachment is obsolete: true
Has Regression Range: --- → yes
Has STR: --- → yes
Depends on: 1452563
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Assignee: nobody → lsalzman
You need to log in before you can comment on or make changes to this bug.