crash while viewing animated gifs with decoding problems.

VERIFIED FIXED in M15

Status

()

Core
Networking
P3
major
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: pnunn, Assigned: pnunn)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Description

18 years ago
I have an odd problem with 2 animated gifs. While testing
them, the browser crashed. I am only putting the platform as
PC, but its probably all.

To reproduce the problem go to
    http://jazz/users/pnunn/publish/
and click on evilpeng.gif and trousers.gif and go back
and forth between the 2 images.

The problem with the images is the igf gathered_data field gets
larger than the maximum read ahead allowed (now set at 60K).

here's the call stack at crash:

ImageConsumer::SetKeepPumpingData(nsIChannel * 0x02ffab90, nsISupports *
0x00000000) line 128 + 15 bytes
ImageConsumer::OnStopRequest(ImageConsumer * const 0x02f62680, nsIChannel *
0x02ffab90, nsISupports * 0x00000000, unsigned int 0, const unsigned short *
0x0012fe6c) line 387
ImageConsumer::KeepPumpingStream(nsITimer * 0x02fcf030, void * 0x02f62680) line
355
TimerImpl::Fire(unsigned long 2543627) line 308 + 17 bytes
TimerImpl::ProcessTimeouts(unsigned long 2543627) line 187
FireTimeout(HWND__ * 0x00000000, unsigned int 275, unsigned int 16514, unsigned
long 2543627) line 101 + 9 bytes
USER32! 77e7185c()
main(int 1, char * * 0x00ae1b90) line 133 + 11 bytes
mainCRTStartup() line 338 + 17 bytes

Updated

18 years ago
Assignee: gagan → pnunn

Comment 1

18 years ago
Pam: You should probably own this. It sounds squarely in the imagelib camp and
doesn't really have anything to do with necko. Also, Gagan's swamped.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

18 years ago
Summary: crash while viewing animated gifs → crash while viewing animated gifs with decoding problems.
Target Milestone: M15
(Assignee)

Comment 2

18 years ago
A fix for bug#6525 looks like it fixed this bug.
but...this still worries me.
An error condition on decoding might not be handled
properly when there is a timer involved.
I'm leaving this bug open with a target of m15 to
remind myself to study this more.
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

18 years ago
fixed by previous checkins.

Comment 4

18 years ago
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.

Comment 5

18 years ago
verified:  NT 2000012520
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.