Closed Bug 1407578 Opened 3 years ago Closed 3 years ago

Unused variable results in build error at jsapi.cpp:850

Categories

(Core :: JavaScript Engine, defect)

Other Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox58 --- fixed

People

(Reporter: kats, Assigned: kats)

References

Details

Attachments

(1 file)

0:45.47 In file included from /Users/kats/zspace/mozilla-w2/obj-host-opt/js/src/Unified_cpp_js_src24.cpp:2:
 0:45.47 /Users/kats/zspace/mozilla-w2/js/src/jsapi.cpp:850:29: error: unused variable 'wp' [-Werror,-Wunused-variable]
 0:45.47         if (WrapperMap::Ptr wp = c->lookupWrapper(origv))
 0:45.47                             ^
 0:45.47 1 error generated.
 0:45.47 make[5]: *** [Unified_cpp_js_src24.o] Error 1
 0:45.47 make[5]: *** Waiting for unfinished jobs....

Regression from bug 1405316.
Attachment #8917327 - Flags: review?(jorendorff)
Comment on attachment 8917327 [details] [diff] [review]
Don't name variable

Review of attachment 8917327 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #8917327 - Flags: review?(jorendorff) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2057d4ff6717
Fix build error due to unused variable. r=jorendorff
https://hg.mozilla.org/mozilla-central/rev/2057d4ff6717
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
You need to log in before you can comment on or make changes to this bug.