Closed Bug 1407638 Opened 2 years ago Closed 2 years ago

[Mac OS] Keyboard shortcut for fullscreen (Cmd+Ctrl+F) doesn't work in Firefox Library

Categories

(Firefox :: Bookmarks & History, defect)

x86_64
macOS
defect
Not set

Tracking

()

RESOLVED INVALID
Tracking Status
firefox56 --- unaffected
firefox57 --- affected
firefox58 --- affected

People

(Reporter: oana.botisan, Assigned: standard8)

References

Details

(Keywords: regression)

[Affected versions]:
- beta 57.0b7
- latest Nightly (2017-10-11)

[Affected platforms]:
- macOS 10.13
- macOS 10.12
- Mac OS 10.11


[Steps to reproduce]:
1. Open hamburger menu and click on Library
2. Click on Download, then on "Show All Downloads"
3. From the keyboard click on Cmd+Ctrl+F

[Expected result]:
- The Library window is on fullscreen mode.

[Actual result]:
- Nothing happens. The window remains the same.

[Regression range]:
- last good build: 2017-09-13 - 20170913220121
- first bad build: 2017-09-14 - 20170914220209

[Additional notes]:
- Fullscreen mode worked only on macOS using keyboard shortcuts.
Summary: [Mac OS] Keyboard shortcut for fullscreen (Cmd+Ctrl+F) don't work in Firefox Library → [Mac OS] Keyboard shortcut for fullscreen (Cmd+Ctrl+F) doesn't work in Firefox Library
(In reply to Oana Botisan from comment #0)
> [Regression range]:
> - last good build: 2017-09-13 - 20170913220121
> - first bad build: 2017-09-14 - 20170914220209

Please post the relevant pushloghtml link for any regression windows you find.
Flags: needinfo?(oana.botisan)
(In reply to :Gijs (blocked reviews; no response to ni until Nov 2 (PTO)) from comment #1)
> (In reply to Oana Botisan from comment #0)
> > [Regression range]:
> > - last good build: 2017-09-13 - 20170913220121
> > - first bad build: 2017-09-14 - 20170914220209
> 
> Please post the relevant pushloghtml link for any regression windows you
> find.

 Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=8645a74bbbd06b67699317df1abf3897db0e43d5&tochange=8e818b5e9b6bef0fc1a5c527ecf30b0d56a02f14

I hope this is helpful. I had to do it manually, because mozregression was not working for this bug.
Flags: needinfo?(oana.botisan)
Component: Theme → Bookmarks & History
I managed to do mozregression for this, not sure what I was doing differently. In any case, I got it down to bug 1402059.

I've not looked in detail yet, but it feels vaguely feasible that it could have caused this. Taking for initial investigation.
Assignee: nobody → standard8
Blocks: 1402059
I've done a bit of digging, and I believe this is not actually a bug. Going back pre-FF 56 (I went back to a 2016-08-01 build for 51.0a1), cmd-ctrl-F would never work.

In FF 56, bug 1381853 landed, which broke how the menus were handled in the library view. In particular, one bit it broke was this:

http://searchfox.org/mozilla-central/rev/31606bbabc50b08895d843b9f5f3da938ccdfbbf/browser/base/content/browser.js#1922

and the menu options weren't getting disabled.

In FF 58 (and 57 betas), bug 1402059 has fixed that so cmd-ctrl-F doesn't work again, i.e. as designed.

There is a strange artefact in the menus, in that we have two "Enter Full Screen" elements, one with the shortcut (disabled), and one without it (enabled). These menus have been this way since at least that 51.0a1 build I tried, so I'm counting that as a separate issue which I've filed bug 1408118 for.

So, all in all, I believe we're now working as intended, so this is invalid / won't fix.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.