Some Installed Plug-ins Do Not Work

VERIFIED DUPLICATE of bug 133282

Status

()

VERIFIED DUPLICATE of bug 133282
17 years ago
16 years ago

People

(Reporter: vgendler, Assigned: rubydoo123)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

Hi,

   I installed RealOne plug-in (the latest RealPlayer).
In the indicated above URL there is a link (right hand, bottom of
the page) "J2EE Web Services Architecture". It should open another
browser window with the RealPlayer plugin. But it reports the browser
has required plug-ins installed and not installed. Among missing ones
is the latest RealPlayer.
I have checked the required DLL is in the Plugins directory.

   Another confirmation of "missing" RealPlayer. In the URL
http://www.russia-in-us.com/Music/Collections/Ofman/russianestrada/index.html
there are a lot of links to the streaming songs. Clicking on any of
them opens a dialog asking the confirmation to open with RealPlayer.
Answering "yes" does nothing.

   Another Plug-ins problem (probably related to this). Open the URL
http://java.sun.com. On the left hand side of this page (close to
the bottom) there is heading "Get local!". Under this heading there is
an applet running. Mozilla does not show it.

   All plug-ins described above work with Netscape 4.X and MS IE
on the same machine.

Reproducible: Always
Steps to Reproduce:
1. See above
2.
3.
Is RealOne in the list you get by selecting "About Plug-ins" from the "Help" menu?

Comment 2

17 years ago
Here are some answers to this long bug report :-)

#1 : cannot verify it, you have to register ?!

#2 : no problem loading and hearing songs. I have Real One player installed, and
no problem.

Do you have nppl3260.dll in plugins folder ?

#3 : I see all applets in java.sun.com pages.

I am using JRE 1.4.0. In order to make it work, you *must* have in plugins folder :

NPOJI610.dll
NPJava11.dll
NPJava12.dll
NPJava13.dll
NPJava32.dll
NPJPI140.dll

Hope I help a little :-)
(Reporter)

Comment 3

17 years ago
Hi,

Comment #1 From Boris Zbarsky:
==============================
Yes, RealOne is in the list I get by selecting "About Plug-ins"
from the "Help" menu. And the indicated DLL in this list in the plugin
directory.


Comment #2 From Frederic Bezies
===============================
#1 : You can register. It is free and takes 10-15 seconds.
#2 : Just double checked it. Rebooted, just in case.
     The same proble. Have you verified on NT (SP6) OS?
     This is a content of my Plugins folder:
        NPJava11.dll
        NPJava12.dll
        NPJava131_01.dll
        NPJava32.dll
        npnul32.dll
        nppdf32.dll
        nprjplug.dll
     I do not have nppl3260.dll in my Plugins folder. But after
     I installed RealOne several minutes ago other browsers play
     the corresponding files.
#3 : I am using JRE 1.3.1. There reasons when I cannot
     go to 1.4.0. Some jave software (IDEs, installation programs)
     do not work with JRE 1.4.0
     But those applets do NOT require 1.4.0.
     a) Other browsers work using JRE 1.3.1.
     b) Besides, even 1.2.X is good to run those applets.

Comment 4

17 years ago
wfm using build 2002042803 on Win2k + JRE 1.4.0 and Real 8 + Real G2 plug-in
(nppl3260.dll): oracle, russian site and java.sun.com.
However, I agree Real on Mozilla is tricky. Dunno about RealOne.
(Reporter)

Comment 5

17 years ago
Some additional info about
Comment #2 From Frederic Bezies:
================================
I have manually copied nppl3260.dll from the Netscape 4.79 Plugin folder
into the Mozilla plugin folder.
Still it does not play.

Comment 6

17 years ago
In answer to comment #3 :

I have NT 5.1 aka XP. For Real One, it install plugins files for Opera (using
nppl3260.dll as plugin). So, I grab it from opera plugin folder to mozilla's one.

For Java, you miss NPOJxxxx.dll, which is very important for applet. You can
find it in Java folder.

Mozilla requires you install plugins by hand !

In answer to comment #4 :

Installing Real One is the same for Real 8. Even if Real says it would not work
with mozilla :-)

In answer to comment #5 :

Do you have entered "about:plugins" in order to /register/ new plugin in Mozilla
? It is tricky, but it work after that.
(Reporter)

Comment 7

17 years ago
Hi,

Comment #6 From Frederic Bezies
===============================
--- For Java, you miss NPOJxxxx.dll.
I checked it. Yes, it works with it.
But I have not missed it. How I supposed to know about it?
Moreover, in order to have Java enabled browser I do not
have to have Java installed on my machine. Java runtime (with all
required DLLs should come with the browser)

--- Mozilla requires you install plugins by hand !
Not necessarily. The problem exists with not ALL plugins (Adobe Acrobat works).
Another question. In spite this is not convenient (to say the least)
to install ALL (!?) plugins by hand how do I know about it?
The installation program did not inform me. The Help | About Plugins
shows the whole bunch of installed plugins and some of them (for instance,
Adobe Acrobat) works fine. I do not agree that this is right.

--- Installing Real One is the same for Real 8
Agree. But it does not do us any good. I install the player.
It DOES NOT say it would not work with Mozilla but the problem
still there. I did one more time a minute ago.

--- Do you have entered "about:plugins" in order to /register/
    new plugin in Mozilla. ? It is tricky, but it work after that.
I can enter there. There is NO either a link or a menu item
to "register" new plugin. I could not also find such in the preferences.

Comment 8

17 years ago
In answer to Comment #8 :

1) There is a bug number in mozilla in order to detect and install plugins like
java at setup time. Cannot remember bug number. :-/

For dll to install, just right click on it and go to properties. It should be
interesting ;-)

JRE is coming with NS 6.x, not Mozilla. License problem ?

2) Having not a lot of information is a /bug/ from plugins creator !

Acrobat is one of the kindest software maker :-) I installed Java, real,
quicktime, Cosmo (for VRML), Windows Media Player, and other plugins.

And in order to know what file to install, Opera is sometimes a good help ;-)

3) Read in http://bugzilla.mozilla.org/show_bug.cgi?id=140717#c10

I now solve the problem.

Realone doesn't add nppl3260.dll in mozilla plugin folder.

I got this file from my friend who is using RealPlayer 8. But this is
incompatible with Realone.

Later I've found that when I installed Realone, it automatically added
nppl3260.dll to Opera plugin folder. I copied it to mozilla. Then everything
works fine. Because I installed Realone earlier than Opera. I could not find the
latest version of nppl3260.dll until I installed Realone for the 2nd time.

Thank you for the help from all.

4) Mozilla seems to "register" its plugins by using "about:mozilla" (without
quotes) URL. (see also help menu).

Hope I help :-)
(Reporter)

Comment 9

17 years ago
Comment #8 From Frederic Bezies
===============================
Yes Realone doesn't add nppl3260.dll in mozilla plugin folder and it does
add it to the Netscape 4.79 Plugins folder.
I added it to the Mozilla Plugins folder. But it DOES NOT solve the problem.
I removed it.
The http://www.geocities.com/ofmang/greg/shockbl2.html page has several
links to the Real stream files. I can play them without nppl3260.dll.
The same is true for the links on the page:
http://members.tripod.com/ogreg/shaov.html.
The common thing between them is that these links point to *.ram files.
The links on the page
http://www.russia-in-us.com/Music/Collections/Ofman/russianestrada/index.html
where I cannot play point to the *.cgi files. I investigate the way how
the play is going. It donwloads a CGI file into Temp directory first.
Then using it is trying to get the real stream and play it. But
for some reasons it fails.
I went to Preferences | Helper Applications and added one entry there:
-----------------------------------
extension: ram rmm
MIME Type: audio/x-pn-realaudio
Location [Full path]\RealPlay.exe
-----------------------------------
"Ask me before opening downloaded files of this type" is checked
(by default) but it does not affect anything??????????
With this entry it started to work. Once again, without this nppl3260.dll!
This dll might be required by Opera and Netscape 4.X but not
Mozilla. I also search the whole system drive where MS IE is.
I did not find this dll there. It means that MS IE does not require it
either. Realone works fine with MS IE.

So this problem is still open.


For dll to install, just right click on it and go to properties.
I did but it opens a small window titled "Element Properties"
with the text "Text language: English". So it does not let me register
anything.

With such tricky things it would be very nice add the ReadMe file to
the installation program to inform about things as Java DLL. I still
do not understand why Mozilla reports that Java plugins installed but
missed some DLLs.
(Reporter)

Comment 10

17 years ago
Comment #8 From Frederic Bezies
Some more info to this.
===============================
A added nppl3260.dll in the Mozilla Plugins folder again.
Then I tried the URL http://otn.oracle.com withe link I reported
in the first posting. It works now. But it is obvious that this
link on the indicated page from the Oracle site uses this DLL to check ONLY
if Realone plugin is installed. I am sure that it does not use it.

Comment 11

17 years ago
In answer to comment #9 :

nppl3260.dll : RealPlayer(tm) G2 LiveConnect-Enabled Plug-In (32-bit)

Mime type : audio/x-pn-realaudio-plugin

So without it, no real support in mozilla. Real One had this file too in his
temporary install folder ~rntemp.

Real One dlls :

- RealOne Player Version NS Plugin (*.*)
- RealPlayer(tm) as Plug-in (*.rpm)

The "Ask me before opening downloaded files of this type" is unchecked on my
mozilla, because I tell mozilla to always open real content with real player
(audio in this case).

Registration is done by mozilla itself. Looking at properties is helpful to know
what a file done.

There is a site with plugins installation, but I lost its url :-/

For java, it is tricky, yes. But Releases notes on mozilla.org website are
helpful too !
(Assignee)

Comment 12

17 years ago
this is a dup of 133282

*** This bug has been marked as a duplicate of 133282 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 13

16 years ago
mass duplicate verifications . For filtering purposes, pls use keywd
"massdupverification"

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.