Open File dialog changes to File Save As ... after double clicking a shortcut (.lnk)

VERIFIED DUPLICATE of bug 80579

Status

Core Graveyard
File Handling
--
critical
VERIFIED DUPLICATE of bug 80579
16 years ago
2 years ago

People

(Reporter: Ian Pottinger, Assigned: Bill Law)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.9+)
Gecko/20020426
BuildID:    2002042608

When I double click on a file or directory shortcut (.lnk) to navigate to the
file I want to open, the Open File dialog changes to a Save File As dialog. 
(Very strange, very unnerving, and potentially very destructive!)

Reproducible: Always
Steps to Reproduce:
1. Create a file or directory shortcut (.lnk) file
2. Double click on the shortcut in the File > Open File ... dialog

Actual Results:  The dialog with title "Open File" disappears and is replace
with a new dialog with title "Enter name of file to save to..."

Also note that the currently displayed directory has change to the default
directory regardless of where the shortcut pointed.

Expected Results:  Double click on a directory shortcut should move you to that
directory. You should should remain in the Open File dialog.

Double click on a file shortcutshould move you to the directory containing that
file.  You should should remain in the Open File dialog.
Duplicate of "File/Open: shortcut(.lnk) does not open original file" (see also
bug 135020).

*** This bug has been marked as a duplicate of 80579 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.