Closed Bug 1407847 Opened 2 years ago Closed 2 years ago

stylo: Enable stylo on XUL document without system principal

Categories

(Core :: CSS Parsing and Computation, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox57 --- wontfix
firefox58 --- fixed

People

(Reporter: xidorn, Assigned: xidorn)

References

Details

Attachments

(1 file)

There are lots of tests running on content-level XUL document which check some XUL functionality. They use backdoors to enable XUL support.

Having stylo run on those tests means we would be able to observe the progress on XUL support of Stylo, and avoid any regression on that support.

Since those backdoors are only enabled in tests as I investigated in bug 1400540 comment 24, removing the XUL document check in UpdateStyleBackendType isn't expected to break anything in the product. If it does, we should blacklist any offending page in ShouldUseGeckoBackend.
Nice one, thanks for doing this Xidorn! :)
Priority: -- → P3
So the biggest issues in terms of test are bug 1408235 (affects everything), bug 1397644 (generates tons of assertions), and bug 1408811 (affects almost all tests involve textbox / editor).
Comment on attachment 8918755 [details]
Bug 1407847 - Enable stylo for XUL document without system principal and annotate failures accordingly.

https://reviewboard.mozilla.org/r/189594/#review194814

::: layout/reftests/reftest.list:407
(Diff revision 1)
>  include ../../dom/tests/reftest/xml-stylesheet/reftest.list
>  
>  # xul-document-load/ (no XUL theme on Android)
> -skip-if(Android) include xul-document-load/reftest.list
> +# skip for stylo because the reference page is wrong due to bug 1408235.
> +# There are some pages rendered incorrectly in the same way, so this
> +# test test set is basically broken and not worth further annotating.

One too many "test"s.
Attachment #8918755 - Flags: review?(cam) → review+
Pushed by xquan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/806b195734ee
Enable stylo for XUL document without system principal and annotate failures accordingly. r=heycam
Pushed by xquan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a4feebaedce8
followup 2 - Adjust some assertions annotation.
Pushed by xquan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4b553367eb72
followup 3 - Update one asserts-if for styloVsGecko.
Pushed by ecoal95@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/9d5720ca5a1b
followup: Adjust crashtest assert count expectation. r=me
Pushed by xquan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/81d815452d89
followup 3 - Adjust some assert count expectation on a CLOSED TREE.
Depends on: 1409604
You need to log in before you can comment on or make changes to this bug.