Closed Bug 1407915 Opened 3 years ago Closed 3 years ago

Crash in java.lang.IllegalStateException: Page URL is required at org.mozilla.gecko.icons.IconRequestBuilder.build(IconRequestBuilder.java)

Categories

(Firefox for Android :: Theme and Visual Design, defect, critical)

58 Branch
Unspecified
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Firefox 58
Tracking Status
firefox-esr52 --- unaffected
firefox56 --- unaffected
firefox57 --- fixed
firefox58 --- fixed

People

(Reporter: calixte, Assigned: jwu)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression, topcrash, Whiteboard: [clouseau][FNC][SPT58.2][INT])

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-0a44a468-32eb-4fca-ad29-06b160171012.
=============================================================

There are 140 crashes in nightly 58 with buildid 20171011100102. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1406338.
The crash is ranked #2 in nightly top-crashers for FennecAndroid.

[1] https://hg.mozilla.org/mozilla-central/rev/5e2772fd3b67
Flags: needinfo?(topwu.tw)
We should prevent loading favicon where the request URL is empty.
Assignee: nobody → topwu.tw
Flags: needinfo?(topwu.tw)
Comment on attachment 8917713 [details]
Bug 1407915 - Ignore loading favicon without url.

https://reviewboard.mozilla.org/r/188640/#review193918
Attachment #8917713 - Flags: review?(cnevinchen) → review+
Pushed by topwu.tw@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/0a322a6a0b07
Ignore loading favicon without url. r=nechen
Comment on attachment 8917713 [details]
Bug 1407915 - Ignore loading favicon without url.

Approval Request Comment
[Feature/Bug causing the regression]:
A regression caused by bug 1406338, we should prevent loading favicon when there is no valid URL.

[User impact if declined]:
If there is a tab contained empty URL, Fennec would crash when user enters tabs tray page.

[Is this code covered by automated tests?]:
No

[Has the fix been verified in Nightly?]:
Not yet

[Needs manual test from QE? If yes, steps to reproduce]: 
Yes, here is the STR:

Prerequisite: Create a new tab with empty URL, however, I don't know how to create a tab without URL, perhaps you have to test several times.

1. Launch Fennec and press the 'tabs' button to enter tabs tray page,
2. Check if the favicon for each tab is shown correctly and app doesn't crash.

[List of other uplifts needed for the feature/fix]:
None

[Is the change risky?]:
No

[Why is the change risky/not risky?]:
We just add an error checking to prevent loading favicon if we get an empty URL.

[String changes made/needed]:
No
Attachment #8917713 - Flags: approval-mozilla-beta?
There seem to be many more crashes on 58 than on 57 - I see only one crash on 57 beta.
Comment on attachment 8917713 [details]
Bug 1407915 - Ignore loading favicon without url.

Low volume, low risk, new crash, Beta57+
Attachment #8917713 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
https://hg.mozilla.org/mozilla-central/rev/0a322a6a0b07
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Whiteboard: [clouseau] → [clouseau][FNC][SPT58.2][INT]
You need to log in before you can comment on or make changes to this bug.