JSON Viewer: navigable (clickable) links (enhancement proposal)

RESOLVED FIXED in Firefox 58

Status

RESOLVED FIXED
2 years ago
9 months ago

People

(Reporter: alek.gurin, Assigned: alek.gurin)

Tracking

57 Branch
Firefox 58

Firefox Tracking Flags

(firefox58 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171009192146
(Assignee)

Comment 1

2 years ago
It would be convenient to have navigable links in JSON viewer. It's really helpful when you browser REST API (e.g. https://api.github.com/).
Attachment #8917982 - Flags: review?(pbrosset)
(Assignee)

Updated

2 years ago
Component: Untriaged → Developer Tools: JSON Viewer
Comment on attachment 8917982 [details] [diff] [review]
json-viewer-clickable-links.patch

Thanks a lot for the patch Aleksander. I'm passing this on to Honza who knows the jsonviewer better than I do.
Attachment #8917982 - Flags: review?(pbrosset) → review?(odvarko)
(Assignee)

Comment 3

2 years ago
OK, Patrick. Thank a lot for quick answer.
(Assignee)

Comment 5

a year ago
It could wait, but my issue is independent (as you can see it is in the code of JSON Viewer, not in Rep library).
Comment on attachment 8917982 [details] [diff] [review]
json-viewer-clickable-links.patch

Review of attachment 8917982 [details] [diff] [review]:
-----------------------------------------------------------------

Nice, thanks for the patch!

R+ (assuming try is green)

Honza
Attachment #8917982 - Flags: review?(odvarko) → review+
(Assignee)

Comment 7

a year ago
Thanks, Jan. Do I need to do something more, or this patch will be added by someone (or maybe by build system)?
Assignee: nobody → alek.gurin
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Keywords: checkin-needed

Comment 9

a year ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0d18dc098eda
JSON Viewer: navigable (clickable) links (enhancement proposal). r=Honza
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/0d18dc098eda
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox58: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58

Comment 11

a year ago
[bugday-20180110]

The issue is no longer reproducible on Firefox 58.0b14 (64-bit)(Build Id: 20180103230655).
Tested in Linux debain 4.10.0-38-generic #42~16.04.1-Ubuntu x86_64

Updated

9 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.