Closed Bug 1408321 Opened 5 years ago Closed 5 years ago

Actors of EvaluationResult messages are not released

Categories

(DevTools :: Console, defect, P1)

defect

Tracking

(firefox58 fixed)

RESOLVED FIXED
Firefox 58
Tracking Status
firefox58 --- fixed

People

(Reporter: nchevobbe, Assigned: nchevobbe)

Details

(Whiteboard: [reserve-console-html])

Attachments

(1 file)

Steps to reproduce:
1. Open the console
2. Evaluate `({a: [1]})`
3. Open the browser toolbox debugger and add a breakpoint on http://searchfox.org/mozilla-central/rev/ed1d5223adcdc07e9a2589ee20f4e5ee91b4df10/devtools/client/webconsole/new-console-output/store.js#217
4. Click the "clear console" button
5. The debugger should pause
6. Inspect the `removedActors` variable

Expected results:
the array contains one actor

Actual results:
the array is empty, and the actor is never released on the server (until the toolbox gets destroyed)
Priority: -- → P3
Whiteboard: [console-html]
Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
Priority: P3 → P1
Comment on attachment 8918226 [details]
Bug 1408321 - Change EvaluationResult message shape to match other messages;.

https://reviewboard.mozilla.org/r/189102/#review194438

::: devtools/client/webconsole/new-console-output/components/message-types/EvaluationResult.js:53
(Diff revision 2)
>    let messageBody;
>    if (message.messageText) {
>      if (typeof message.messageText === "string") {
>        messageBody = message.messageText;
>      } else if (
>        typeof message.messageText === "object"

Do we need to deal with string / longstring results in a similar manner?
Attachment #8918226 - Flags: review?(bgrinstead) → review+
So, I do think we need to keep the messageText property, since it's used in every component, but yes, we should release actors if messageText is a longstring, which I think we don't do for now.
Let's handle longStrings in Bug 1408845
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5e8fe51d3a1c
Change EvaluationResult message shape to match other messages;r=bgrins.
Whiteboard: [console-html] → [reserve-console-html]
https://hg.mozilla.org/mozilla-central/rev/5e8fe51d3a1c
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.