Mozilla will not download files with long names

VERIFIED DUPLICATE of bug 139360

Status

SeaMonkey
Download & File Handling
--
major
VERIFIED DUPLICATE of bug 139360
16 years ago
14 years ago

People

(Reporter: Josh Whitver, Assigned: Blake Ross)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.0+)
Gecko/20020428
BuildID:    2002042808

If a file to be downloaded has a long name, Mozilla will choke on it and simply
not download the file.  I haven't tested this exhaustively, but the limit
appears to be in the upper 20's for number of characters (perhaps it's 31...the
old Mac filename limit??).



Reproducible: Always
Steps to Reproduce:
1. Go to URL above (or any place that has files with long names to download)
2. Click the "Test file with Super Long Name.txt" file
3. Note how Mozilla offers to download it (for some reason appending a .binary
on the end of it...which is another issue altogether)
4. Note how, when clicking "Save" nothing happens.

Actual Results:  Mozilla does not download the file.

Expected Results:  Mozilla should have downloaded the file properly (and not
appended .binary, but again, that's another issue).

Comment 1

16 years ago
Everything appears right using RC1, but the file is never actually saved.

Comment 2

16 years ago
This is a duplicate of bug 139360.

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 139360 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.