Closed Bug 1408418 Opened 4 years ago Closed 4 years ago

Permafail QuantumRender tcanvasmark | Could not find report in browser output: [('tsformat', ('__start_report', '__end_report')), ('tpformat', ('__start_tp_report', '__end_tp_report'))]

Categories

(Testing :: Talos, defect, P5)

Version 3
defect

Tracking

(firefox58 fixed)

RESOLVED FIXED
mozilla58
Tracking Status
firefox58 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: kats)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Filed by: archaeopteryx [at] coole-files.de

https://treeherder.mozilla.org/logviewer.html#?job_id=136630157&repo=mozilla-central

https://archive.mozilla.org/pub/firefox/tinderbox-builds/mozilla-central-linux64-qr/mozilla-central_ubuntu64_hw_qr_test-chromez-e10s-bm105-tests1-linux-build2.txt.gz

This permafails on QuantumRender, see https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&filter-searchStr=51884d7856da2e2fd919ae8e48fd33ce18af88e8&tochange=196dadb2fe500e75c6fbddcac78106648676cf10&selectedJob=136630157

03:14:55     INFO -  TEST-INFO | started process 7861 (/builds/slave/test/build/application/firefox/firefox -profile /tmp/tmpT2SLSH/profile -tp file:/builds/slave/test/build/tests/talos/talos/tests/canvasmark/canvasmark.manifest.develop -tpchrome -tpnoisy -tpcycles 5 -tppagecycles 1)
03:14:56     INFO -  PID 7861 | WebRender - OpenGL version new 3.2.0 NVIDIA 361.42
03:14:56     INFO -  PID 7861 | WebRender - OpenGL version new 3.2.0 NVIDIA 361.42
03:14:57     INFO -  PID 7861 |
03:14:57     INFO -  PID 7861 | (/builds/slave/test/build/application/firefox/firefox:7921): Pango-WARNING **: error opening config file '/home/cltbld/.pangorc': Permission denied
03:14:57     INFO -  PID 7861 |
03:15:49     INFO -  PID 7861 | ExceptionHandler::GenerateDump cloned child 8054
03:15:49     INFO -  PID 7861 | ExceptionHandler::SendContinueSignalToChild sent continue signal to child
03:15:49     INFO -  PID 7861 | ExceptionHandler::WaitForContinueSignal waiting for continue signal...
03:15:50     INFO -  PID 7861 | [Child 8013, Chrome_ChildThread] WARNING: pipe error (3): Connection reset by peer: file /builds/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
03:15:50     INFO -  Terminating psutil.Process(pid=7861, name='firefox')
03:15:50     INFO -  TEST-INFO | 7861: exit 7
03:15:50     INFO -  TEST-UNEXPECTED-ERROR | tcanvasmark | Could not find report in browser output: [('tsformat', ('__start_report', '__end_report')), ('tpformat', ('__start_tp_report', '__end_tp_report'))]
03:15:50    ERROR -  Traceback (most recent call last):
03:15:50     INFO -    File "/builds/slave/test/build/tests/talos/talos/run_tests.py", line 276, in run_tests
03:15:50     INFO -      talos_results.add(mytest.runTest(browser_config, test))
03:15:50     INFO -    File "/builds/slave/test/build/tests/talos/talos/ttest.py", line 61, in runTest
03:15:50     INFO -      return self._runTest(browser_config, test_config, setup)
03:15:50     INFO -    File "/builds/slave/test/build/tests/talos/talos/ttest.py", line 271, in _runTest
03:15:50     INFO -      else None)
03:15:50     INFO -    File "/builds/slave/test/build/tests/talos/talos/results.py", line 95, in add
03:15:50     INFO -      global_counters=self.global_counters
03:15:50     INFO -    File "/builds/slave/test/build/tests/talos/talos/results.py", line 326, in __init__
03:15:50     INFO -      self.parse()
03:15:50     INFO -    File "/builds/slave/test/build/tests/talos/talos/results.py", line 353, in parse
03:15:50     INFO -      % self.report_tokens)
03:15:50     INFO -    File "/builds/slave/test/build/tests/talos/talos/results.py", line 337, in error
03:15:50     INFO -      raise utils.TalosError(message)
03:15:50     INFO -  TalosError: Could not find report in browser output: [('tsformat', ('__start_report', '__end_report')), ('tpformat', ('__start_tp_report', '__end_tp_report'))]
03:15:50     INFO -  TEST-INFO took 60896ms
Thanks, I'll track down what regressed this (and probably disable it in the meantime).
Assignee: nobody → bugmail
Flags: needinfo?(bugmail)
This is the regression range: https://hg.mozilla.org/mozilla-central/pushloghtml?changeset=25aad10380b10b6efa50c2b4d97245f078d870a0

I have try pushes going to bisect this further, since apparently I can't just add talos qr jobs to existing inbound pushes. The two most likely candidates are bug 1405481 and bug 1403539, so I did try pushes with those to start:

@ 077b6ec36d84 -> https://treeherder.mozilla.org/#/jobs?repo=try&revision=210a0784732111db86ffae81d52b382603f9268f
@ b3dddc032e3d -> https://treeherder.mozilla.org/#/jobs?repo=try&revision=852fd058a2747f03828f6613b226fc798fb10471
Actually bug 1407480 might also fix this, I'll see if I can confirm that.
Comment on attachment 8918334 [details]
Bug 1408418 - Disable talos-chrome on QR builds because they are permafailing.

https://reviewboard.mozilla.org/r/189138/#review194462
Attachment #8918334 - Flags: review?(jmuizelaar) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a9a3eb7320f5
Disable talos-chrome on QR builds because they are permafailing. r=jrmuizel
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #2)
> I have try pushes going to bisect this further, since apparently I can't
> just add talos qr jobs to existing inbound pushes. The two most likely
> candidates are bug 1405481 and bug 1403539, so I did try pushes with those
> to start:
> 
> @ 077b6ec36d84 ->
> https://treeherder.mozilla.org/#/
> jobs?repo=try&revision=210a0784732111db86ffae81d52b382603f9268f
> @ b3dddc032e3d ->
> https://treeherder.mozilla.org/#/
> jobs?repo=try&revision=852fd058a2747f03828f6613b226fc798fb10471

Both these show failures in the talos test, so that narrows the range to https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=39d2b1b24e0f&tochange=077b6ec36d84 which means it's almost certainly bug 1405481. I'm doing another try push at 1d25638f204d to confirm: https://treeherder.mozilla.org/#/jobs?repo=try&revision=80e20c430b58ee4c05b2145c81b9aabe626fc999
Confirmed. Sotaro, if you have some time, can you look into why bug 1405481 caused this talos test to permafail?
Blocks: 1405481
Flags: needinfo?(sotaro.ikeda.g)
https://hg.mozilla.org/mozilla-central/rev/a9a3eb7320f5
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #9)
> Confirmed. Sotaro, if you have some time, can you look into why bug 1405481
> caused this talos test to permafail?

Thanks! I created a bug Bug 1408635. I will look into it.
Flags: needinfo?(sotaro.ikeda.g)
See Also: → 1408635
You need to log in before you can comment on or make changes to this bug.