Crash in mozalloc_abort | abort | webrender::prim_store::{{impl}}::prepare_prim_for_render_inner

RESOLVED WONTFIX

Status

()

defect
--
critical
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: marcia, Assigned: jerry)

Tracking

(Blocks 1 bug, {crash, regression})

Trunk
Unspecified
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 unaffected, firefox58 unaffected)

Details

(crash signature)

This bug was filed from the Socorro interface and is 
report bp-a253c5ad-3914-424b-806a-adbd40171012.
=============================================================

Seen while looking at Mac crash stats. All crashes are happening on 10.13: http://bit.ly/2xDOl3v

I can add some URLs if that will help.
Whiteboard: [wr-mvp] [triage]
Priority: P3 → P2
Whiteboard: [wr-mvp] [triage] → [wr-mvp]
Got the following information from the crash report, it looks like font related issues.

MozCrashReason 	
assertion failed: self.font_contexts.lock_shared_context().has_font(&font.font_key)
There are still crash reports with this signature on Oct 24 builds. The crash reason is the same, and the only code that matches is at http://searchfox.org/mozilla-central/rev/d30462037ffea383e74c42542c820cf65b2b144e/gfx/webrender/src/glyph_rasterizer.rs#178

/cc Lee because... fonts. Also /cc nical because this assertion was added by him in WR commit 7ef93f44d3cb6.
I can reproduce this crash on Mac nightly by loading https://t.co/okjwLb98Ke from a link in Twitter. 100% reproducible.
See Also: → 1413571
I had to turn off webrender in nightly, because I am crashing so frequently on my 10.13 machine.
Marcia, do you have blob-images turned on? Can you still reproduce it if you turn them off?
Flags: needinfo?(mozillamarcia.knous)
(In reply to Jeff Muizelaar [:jrmuizel] from comment #5)
> Marcia, do you have blob-images turned on? Can you still reproduce it if you
> turn them off?

No, that pref is set to false. I can repro using the link in Comment 3. The other data point is I am running ahead on 10.13.2 (17C60c). Lots of times when I initiate a click into a tab the whole browser goes down.
Flags: needinfo?(mozillamarcia.knous)
I can also reproduce this in my machine. My MacOS version is 10.13.1 and I only turned on pref "gfx.webrender.enabled".
Blocks: highsierra
I can 100% reproduce with my 10.13 mac. I will check this.
Assignee: nobody → hshih
Status: NEW → ASSIGNED
For the test link: http://bit.ly/2xDOl3v, it will create a big shmem data(120mb) for font data. Then, the shmem creation is failed.
I think that's the reason that why wr can't find the font data for the specific font key.
Priority: P2 → P1
With Bug 1403198, there is no raw font data in ipc. And I don't see the crash with Bug 1403198.
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Depends on: 1403198
Resolution: --- → WONTFIX
Priority: P1 → --
Whiteboard: [wr-mvp]
(In reply to Jerry Shih[:jerry] (UTC+8) from comment #10)
> With Bug 1403198, there is no raw font data in ipc. And I don't see the
> crash with Bug 1403198.

Awesome! An early font descriptor win.
See Also: → 1425181
You need to log in before you can comment on or make changes to this bug.