Closed Bug 1408445 Opened 3 years ago Closed 3 years ago

Crash in java.lang.IllegalArgumentException: codec does not support type at android.os.Parcel.readException(Parcel.java)

Categories

(Firefox for Android :: Audio/Video, defect)

Unspecified
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Firefox 58
Tracking Status
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- fixed

People

(Reporter: mccr8, Assigned: jhlin)

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-960a070b-5ab1-4036-967f-50ba30171008.
=============================================================

This looks related to mozilla::H264Converter::Init. This is a Nightly-only crash, starting on the 20171007100128 build. It isn't clear to me how many distinct installations are actually involved here, but it has been happening on more than one day since the 7th. Some YouTube urls in the crashes.
It's caused by bug 1403849. Turns out MediaCodecInfo.getCapabilitiesForType() throws runtime exception rather than returns empty capabilities when none declared.
Assignee: nobody → jolin
Comment on attachment 8918619 [details]
Bug 1408445 - handle exception when querying codec capabilities.

https://reviewboard.mozilla.org/r/189462/#review194852
Attachment #8918619 - Flags: review?(esawin) → review+
Pushed by jolin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1dfddc19749e
handle exception when querying codec capabilities. r=esawin
https://hg.mozilla.org/mozilla-central/rev/1dfddc19749e
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
You need to log in before you can comment on or make changes to this bug.