Closed Bug 1408484 Opened 2 years ago Closed 2 years ago

Sign partial updates with SHA384 on Thunderbird beta builds.

Categories

(Thunderbird :: Build Config, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: tomprince, Assigned: tomprince)

Details

Attachments

(3 files, 2 obsolete files)

The complete updates are signed by in-tree code which was updated to request the new format. Unfortunately, partial updates are signed by code invoked directly from buildbotcustom and build/tools so didn't get updated.
Assignee: nobody → mozilla
Comment on attachment 8918403 [details]
Bug 1408484: Sign release partials with SHA384 when requested.

https://reviewboard.mozilla.org/r/189232/#review194552
Attachment #8918403 - Flags: review?(bugspam.Callek) → review+
Comment on attachment 8918404 [details]
Bug 1408484: Don't push thunderbird betas to mirrors automatically.

https://reviewboard.mozilla.org/r/189222/#review194554
Attachment #8918404 - Flags: review?(bugspam.Callek) → review+
Comment on attachment 8918405 [details]
Bug 1408484: Specify that Thunderbird betas should be signed with SHA384.

https://reviewboard.mozilla.org/r/189224/#review194556
Attachment #8918405 - Flags: review?(bugspam.Callek) → review+
Comment on attachment 8918406 [details]
Bug 1408484: Sign release partials with SHA384 when requested.

https://reviewboard.mozilla.org/r/189228/#review194558
Attachment #8918406 - Flags: review?(bugspam.Callek) → review+
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Attachment #8918404 - Attachment is obsolete: true
Attachment #8918405 - Attachment is obsolete: true
Comment on attachment 8920945 [details]
Bug 1408484: Re-enable automatic pushes to mirrors;

https://reviewboard.mozilla.org/r/189220/#review197078

Since the issue the caused 10+ builds has been addressed, I think it makes sense to revert this. My impression was that pushing manually required a fair amount of effort, and I don't think I have access to initiate it. So I think on balance, it makes sense to have the push be automatic.
Comment on attachment 8920945 [details]
Bug 1408484: Re-enable automatic pushes to mirrors;

https://reviewboard.mozilla.org/r/189220/#review197440

Yes, I think that's fine too.
Attachment #8920945 - Flags: review?(nthomas) → review+
You need to log in before you can comment on or make changes to this bug.