Closed Bug 1408539 Opened 2 years ago Closed 2 years ago

Onboarding Tour: update customize, library, and screenshot illustration

Categories

(Firefox :: Tours, defect, P3, trivial)

58 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 58
Tracking Status
firefox57 --- verified
firefox58 --- verified

People

(Reporter: jdavidson, Assigned: gasolin)

References

Details

(Whiteboard: [photon-onboarding][photon-onboarding-newui])

Attachments

(5 files)

As per the following description on a different bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1399142#c0

Remove the Pocket icon from the Customize illustration in the Onboarding Tour because Pocket cannot be customized. 

Attached is the original Customize panel in the Onboarding Tour overlay.
Smartell could you help on provide new illustration?
Flags: qe-verify+
Flags: needinfo?(smartell)
Priority: -- → P3
Whiteboard: [photon-onboarding][photon-onboarding-newui]
Target Milestone: --- → Firefox 58
Component: New Tab Page → Tours
Attached image customize.svg
Fixed
Flags: needinfo?(smartell)
Depends on: 1399142
I saw you update library & screenshot svg in bug 1399142, do you think we need those 2 changes as well in v57?
We can update these 3 illustrations at once in this bug.
Flags: needinfo?(smartell)
verdi/bryant I need your help to provide these 3 svg in right default size & tune for the optimize size through  https://jakearchibald.github.io/svgomg/
Flags: needinfo?(mverdi)
Flags: needinfo?(bmao)
Fred, to be confirmed, are you referring to the library, screenshot, and customized illustration? And do you want us to adjust the frame size to 352x303 and under 80kb?
Flags: needinfo?(bmao)
Yes, please
SVG attached, see if that works.
Flags: needinfo?(mverdi)
via email:
"We can update 3 illustration updates in bug 1408539 at once, without re-uplift bug 1399142"

Hi Fred,
If we plan on taking this course of action, can you please update the bug name so it clearly depicts that we are updating all 3 illustrations and not just the customize illustration.
Flags: needinfo?(gasolin)
Flags: needinfo?(gasolin)
Summary: Onboarding Tour: Remove Pocket icon from Customize illustration → Onboarding Tour: update customize, library, and screenshot illustration
Hi Bryant, the compressed files size are still too large (200k, 106k) compare to the existing one (~70k).
I can't see the big difference between old and new one so they might able to compress to the same level file size, 
can you help double check if we can compress them more?
Flags: needinfo?(smartell) → needinfo?(bmao)
Assignee: nobody → gasolin
Hey Fred, I've tried the compression again, see the latest attachment. So far, the customize SVG is still around 100k, not sure if that work for you. 

If not, we might need to ask Sean to check the illustration again to see if there are redundant layers that can be removed (the current layer number is twice as much than the original one, even the pocket icon removed)
Flags: needinfo?(bmao)
Thanks, the patch comes with 3 updated illustrations
(In reply to Bryant Mao [:bryantmao] from comment #10)
> Created attachment 8922607 [details]
> customize_library_screenshot_svg_1027(compressed).zip
> 
> Hey Fred, I've tried the compression again, see the latest attachment. So
> far, the customize SVG is still around 100k, not sure if that work for you. 
> 
> If not, we might need to ask Sean to check the illustration again to see if
> there are redundant layers that can be removed (the current layer number is
> twice as much than the original one, even the pocket icon removed

Hi Sean, can you possibly check if you can still make the size of the Customize SVG smaller? It will help the tour load faster.
Flags: needinfo?(smartell)
Comment on attachment 8922679 [details]
Bug 1408539 - Onboarding Tour: update customize, library, and screenshot illustration;

https://reviewboard.mozilla.org/r/193818/#review198976
Attachment #8922679 - Flags: review?(fliu) → review+
Pushed by flin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7b78af3ab388
Onboarding Tour: update customize, library, and screenshot illustration;r=Fischer
The images look good and already in the reasonable size. I think we shouldn't be blocked by waiting more days for further downsize images when we want to present these images in v57.
Flags: needinfo?(smartell)
https://hg.mozilla.org/mozilla-central/rev/7b78af3ab388
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Comment on attachment 8922679 [details]
Bug 1408539 - Onboarding Tour: update customize, library, and screenshot illustration;

Approval Request Comment
[Feature/Bug causing the regression]:
[User impact if declined]: img shows pocket icon in customize tour but it can't be customized, the rest 2 modification are based on research feedback
[Is this code covered by automated tests?]: N
[Has the fix been verified in Nightly?]: N, manual checked images are updated 
[Needs manual test from QE? If yes, steps to reproduce]: open onboarding and check all tours. go to about:config to change pref "browser.onboarding.tour-type" from `new` to `update`, refresh and wait several seconds to check update user tour sets.
[List of other uplifts needed for the feature/fix]: N
[Is the change risky?]: N
[Why is the change risky/not risky?]: image update only
[String changes made/needed]: N
Attachment #8922679 - Flags: approval-mozilla-beta?
Comment on attachment 8922679 [details]
Bug 1408539 - Onboarding Tour: update customize, library, and screenshot illustration;

Low risk, Onboarding Tour related, Beta57+
Attachment #8922679 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
I reproduced this issue using Fx 58.0a1, build ID: 20171013220204, on Windows 10 x64.
I can confirm this issue is fixed, I verified using Fx 58.0a1, build ID: 20171102100041, and Fx 57.0b14, on Windows 10 x64, Ubuntu 14.04 LTS and mac OS X 10.13.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.