Could not connect to the server; the connection was refused.

VERIFIED INVALID

Status

MailNews Core
Networking: NNTP
VERIFIED INVALID
16 years ago
10 years ago

People

(Reporter: Salim Fadhley, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
This error message is just to vague to be of any use for anybody who uses lots
of mail and news accounts... it's often hard to work out exactly which server
refused the connection.

This error message happens when I click on one of the newsgroups of my ISP's
news server.

:-)
Adding Cavin, since he fixed bug 100167.

Note, using search query:
http://lxr.mozilla.org/seamonkey/search?string=the+connection+was+refused

/docshell/base/appstrings.properties, line 24 -- connectionFailure=The
connection was refused when attempting to contact %s.
/netwerk/base/src/nsSocketTransport.cpp, line 914 -- // The connection was
refused...
/mailnews/base/resources/locale/en-US/messenger.properties, line 216 --
103=Could not connect to server %S; the connection was refused.
/mailnews/imap/resources/locale/en-US/imapMsgs.properties, line 273 --
5053=Could not connect to mail server %S; the connection was refused.

So, I can't see where this is coming from.

Comment 2

16 years ago
Reporter, what version of mozilla are you running on?
(Reporter)

Comment 3

16 years ago
Sory, this is Mozilla 1, Release Candidate 1. 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0rc1) Gecko/20020417
Running on Windows XP

This Bug/Feature is quite an old one and can also be seen in older versions of
Netscape mail. 

Any time an Imap or new server fails to connect, a user is given that vague
message. An easy way to re-create that message is change the IP address of the
server you are trying to connect to to something that does not exist. After a
few moments of trying to connect, Mozilla Mail will complain, and you will see
the vague error message.

IMO, it should at least state the name of the server that it was trying to
connect to, and some clue about why it failed - for example the machine could
not be contacted or that the machine could be contacted but the IMAP connection
was refused. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
No, for me, changing the name of the server works, if I change my valid
(dredd.netscape.com) entry for my IMAP server to be dredd1.netscape.com we say
'Failed to connect to server dredd1.netscape.com'.

Honestly the string in your subject doesn't exist - the only thing I can think
of is that after the 'server;' portion, we are supposed to specify the
servername and for some reason yours isn't coming through; which is a bug, if
true.  But I can't reproduce that.
verified invalid.  I still can't reproduce this; let me know if you have a
server/setup/scenario that exhibits this.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.