Closed Bug 1408607 Opened 2 years ago Closed 2 years ago

Buttons in ProtonMail scrollable e-mail body div don't work unless window is maximized

Categories

(Core :: Layout, defect, P3)

defect

Tracking

()

VERIFIED FIXED
mozilla58
Tracking Status
firefox-esr52 --- unaffected
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- fixed

People

(Reporter: ehoogeveen, Assigned: tnikkel)

References

Details

(Keywords: regression)

Attachments

(3 files)

When you load an e-mail in ProtonMail, the div on the right of the two-column view is briefly blank before being populated with the decrypted message. As of today's Nightly, I found that if the e-mail thread is long enough to require a vertical scrollbar, buttons and links in the scrollable div cannot be interacted with - unless the browser window is maximized. Messages can still be collapsed or expanded however.

The reduced regression range contains a few bugs, but only bug 1405397 seems like a likely candidate:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=0160c57b65d9b28c04eb78a1bba905ea57d23119&tochange=8adc032add4e21b85ff4eaa31ae0074434dc2a12

Steps to reproduce:
1) From a fresh profile, login to your ProtonMail account. Make sure it's set to the two-column layout.
2) Make sure the browser window isn't maximized.
3) Open an e-mail thread long enough to require a vertical scrollbar (either by default, or after expanding collapsed messages).
4) Hover over any of the buttons in the message header (such as Reply).

Expected results:
Cursor turns into a hand icon and you can click the button.

Actual results:
Cursor stays as the arrow, and clicking the button does nothing.
Flags: needinfo?(tnikkel)
Thanks for tracking this down. Can you try the try build that will appear here shortly?

https://treeherder.mozilla.org/#/jobs?repo=try&revision=129edf2077e1d4f8f9b0d359dc4285897897d47e
Flags: needinfo?(emanuel.hoogeveen)
Priority: -- → P3
That was quick, thanks! I can't reproduce the problem using the try build.
Flags: needinfo?(emanuel.hoogeveen)
Bug 1408402 might be the same issue.
(In reply to Emanuel Hoogeveen [:ehoogeveen] from comment #3)
> Bug 1408402 might be the same issue.

The try build from :tnikkel fixed it for me, so it seems to be the same issue.
Duplicate of this bug: 1408402
Assignee: nobody → tnikkel
Flags: needinfo?(tnikkel)
Attachment #8918707 - Flags: review?(mstange)
Looks like it's important to only do displayport stuff when painting to the window and not event handling.
Attachment #8918708 - Flags: review?(mstange)
Attachment #8918707 - Flags: review?(mstange) → review+
Attachment #8918708 - Flags: review?(mstange) → review+
Pushed by tnikkel@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/fbbdc0131e35
mWillBuildScrollable only keeps updated during display list building. So change Is(Maybe)ScrollingActive to not use it so they are always accurate. r=mstange
https://hg.mozilla.org/integration/mozilla-inbound/rev/3f2f733d6ab2
Make all uses of mWillBuildScrollableLayer conditional on painting to the window. r=mstange
Duplicate of this bug: 1408803
Duplicate of this bug: 1409003
Duplicate of this bug: 1409059
It would be nice to add a test for at least one of the manifestations of this bug.
Thanks for the test case.
Blocks: 1408952
Nightly 58 x64 20171017141229 de_DE @ Debian Testing
Whatsapp+Telegram: Enlarging images, clicking on links and per message menus are working again.
Thank you! :)
I can also confirm that ProtonMail works as normal again. Thanks!
Status: RESOLVED → VERIFIED
No longer blocks: 1408952
Duplicate of this bug: 1408952
Duplicate of this bug: 1408755
Duplicate of this bug: 1379887
You need to log in before you can comment on or make changes to this bug.