Closed Bug 1408707 Opened 2 years ago Closed 2 years ago

opening local .URL file tries to open relative links locally

Categories

(Core :: Networking: File, defect)

56 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1405199

People

(Reporter: ndx47a3, Assigned: mayhemer)

Details

(Whiteboard: [necko-triaged])

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20171002220106

Steps to reproduce:

1: bookmark an online URL  2: drag link to a local folder as a .url shortcut file 3: double-click .url file and have online page load 4: try to click a relative URL on the page to other pages on the site and 4b: the browser precedes the relative link with file:// thereby invalidating the relative URL on the site.


Actual results:

the browser precedes the relative link with file:// thereby invalidating the relative URL on the site.


Expected results:

the correct online page should have loaded. try any of the top heading links: Technologies, References & Guides, Feedback.
Component: Untriaged → Networking: File
Product: Firefox → Core
Maybe caused by bug 1405199?
Flags: needinfo?(honzab.moz)
Actually, it's reported on 56, so most likely a dupe.
Yeah, I don't think it's regression from bug 1405199.  This should either be fixed with that bug or is regression from bug 1319111 that was hidden until bug 1405199 was fixed.
Assignee: nobody → honzab.moz
Flags: needinfo?(honzab.moz)
Whiteboard: [necko-triaged]
(In reply to ndx47a3 from comment #0)
> 4: try to click a
> relative URL on the page to other pages on the site and 4b: the browser
> precedes the relative link with file:// thereby invalidating the relative
> URL on the site.

Yes, based on the description, this bug is a duplicate of bug 1405199.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1405199
You need to log in before you can comment on or make changes to this bug.