The non-selected elements with ids should be lightened to the same color as the non-selected classes

RESOLVED FIXED in Firefox 58

Status

enhancement
P3
normal
RESOLVED FIXED
2 years ago
Last year

People

(Reporter: hodginsl2, Assigned: hodginsl2)

Tracking

unspecified
Firefox 58

Firefox Tracking Flags

(firefox58 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

2 years ago
No description provided.
Assignee: nobody → hodginsl2
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P3
Attachment #8918696 - Flags: review?(gl)

Comment 2

2 years ago
mozreview-review
Comment on attachment 8918696 [details]
Bug 1408790 - The non-selected elements with ids should be lightened to the same color as the non-selected classes

https://reviewboard.mozilla.org/r/189506/#review199874

::: devtools/client/themes/breadcrumbs.css:166
(Diff revision 1)
>  
>  .theme-light .breadcrumbs-widget-item {
>    color: var(--theme-body-color);
>  }
>  
>  .breadcrumbs-widget-item-id {

So, we should just make this one rule since both items are gonna have the same color. I am also gonna just say we should hardcode it to var(--grey-40) for both light/dark theme. Maybe also do a check with Victoria afterwards. It seems to me that we were fine with the light grey in the id (--grey-40) in the light theme originally. The class is grey-30 in the dark theme, and having it as grey-40 also looks ok. Alternatively, we would have both the classes and id as grey-40 in the light theme and grey-30 in the dark theme.

.breadcrumbs-widget-item-classes,
.breadcrumbs-widget-item-id {
  color: var(--grey-40)
}
Attachment #8918696 - Flags: review?(gl)
Comment hidden (mozreview-request)

Comment 4

2 years ago
mozreview-review
Comment on attachment 8918696 [details]
Bug 1408790 - The non-selected elements with ids should be lightened to the same color as the non-selected classes

https://reviewboard.mozilla.org/r/189506/#review202704
Attachment #8918696 - Flags: review?(gl) → review+

Comment 5

2 years ago
Pushed by gabriel.luong@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ac9d12e5587f
The non-selected elements with ids should be lightened to the same color as the non-selected classes r=gl

Comment 6

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/ac9d12e5587f
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58

Updated

Last year
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.