Last Comment Bug 140882 - Mail/News: Date Time in English format in changed quote start
: Mail/News: Date Time in English format in changed quote start
Status: RESOLVED FIXED
: intl
Product: MailNews Core
Classification: Components
Component: Internationalization (show other bugs)
: Trunk
: x86 Windows NT
: -- trivial (vote)
: mozilla1.2alpha
Assigned To: nhottanscp
: ji
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-29 03:57 PDT by Ansgar Schrage
Modified: 2008-07-31 01:22 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Changed a deafult value of "mailnews.reply_header_locale" from "en-US" to empty. (914 bytes, patch)
2002-07-17 17:25 PDT, nhottanscp
rchen: review+
mozilla: superreview+
Details | Diff | Splinter Review

Description Ansgar Schrage 2002-04-29 03:57:35 PDT
From Bugzilla Helper German:

proposed Product: Browser+Localizations
proposed Component: German-Austria/de-AT

User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; de-AT; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

When you change your prefs.js to change the beginning of a quote in a reply
eMail in the following way:

user_pref("mailnews.reply_header_ondate", "Am %s");
user_pref("mailnews.reply_header_separator", ", ");
user_pref("mailnews.reply_header_authorwrote", "%s schrieb");
user_pref("mailnews.reply_header_colon", ":");
user_pref("mailnews.reply_header_type", 2);

the displayed time and date are in English format.

Reproducible: Always

Actual Results:  
Am 4/28/02 5:29 PM, Ansgar Schrage schrieb:
> 

Expected Results:  
Am 28.04.02 17:29, Ansgar Schrage schrieb:
>
Comment 1 Robert Kaiser 2002-05-11 09:04:03 PDT
What time format does your OS use by default? I once heard we would default to
OS settings for such things.

Not sure though, over to MailNews.
Comment 2 Ansgar Schrage 2002-05-11 11:03:05 PDT
My OS is set to use the German time format by default.
Comment 3 ji 2002-05-11 14:10:31 PDT
Confirmed with the latest branch build.
Comment 4 Dave Roberts 2002-05-23 07:24:12 PDT
To be exact, the format of "4/28/02 5:29 PM" is the American format.  And I also
experience this problem.  I'm using RC2 no Win2000.  My locale in Windows is set
to English (UK), as such my date and time should come out like "28/04/02 17:29",
but I also see the American string as reported.

In testing, I changed my locale back to English (US), and I then specifically
tweaked the date/time format within the Regional Settings Control Panel. 
Mozilla picked up these changes properly.  Of course, this made other programs
unusable for me, so I had to revert back.

So, IMHO, the problem is that the locale settings are only being read if the
locale is set to English (US), otherwise the settings are ignored, and a default
of US is being applied.
Comment 5 John Mark Williams 2002-07-08 10:46:03 PDT
I've had exactly the same experience as Dave Roberts above (except that I'm
using a different build). However, I managed to fix it with this line in my user.js:

  user_pref("mailnews.reply_header_locale", "en-GB");

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a) Gecko/2002061104
Comment 6 rchen 2002-07-09 14:44:45 PDT
->nhotta.
Comment 7 nhottanscp 2002-07-17 17:25:09 PDT
Created attachment 91731 [details] [diff] [review]
Changed a deafult value of "mailnews.reply_header_locale" from "en-US" to empty.
Comment 8 Ansgar Schrage 2002-07-18 04:09:05 PDT
I checked it on my PC by adding the line
'user_pref("mailnews.reply_header_locale", "");' manually to my prefs.js. Now it
looks like this:

Am 18.07.2002 12:59, Ansgar Schrage schrieb:

And that is what I have expected :-)
Good job!
Comment 9 nhottanscp 2002-07-18 10:35:15 PDT
Ray, could you review the patch?
Comment 10 marina 2002-07-31 11:53:11 PDT
*** Bug 160346 has been marked as a duplicate of this bug. ***
Comment 11 rchen 2002-08-12 18:16:12 PDT
Comment on attachment 91731 [details] [diff] [review]
Changed a deafult value of "mailnews.reply_header_locale" from "en-US" to empty.

r=rchen
Comment 12 David :Bienvenu 2002-08-15 13:10:25 PDT
Comment on attachment 91731 [details] [diff] [review]
Changed a deafult value of "mailnews.reply_header_locale" from "en-US" to empty.

sr=bienvenu
Comment 13 nhottanscp 2002-08-15 15:39:20 PDT
checked in to the trunk

Note You need to log in before you can comment on or make changes to this bug.