Closed Bug 1408824 Opened 2 years ago Closed 2 years ago

stylo: various XUL elements are sized incorrectly

Categories

(Core :: CSS Parsing and Computation, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1408811
Tracking Status
firefox57 --- wontfix
firefox58 --- affected

People

(Reporter: xidorn, Unassigned)

References

Details

(Note that this is filed for annotating tests in the progress of bug 1407847. The test is not going to fail without patch there, because XUL is still using Gecko backend at the moment.)

This is a stylo vs. gecko reftest failure on layout/reftests/bugs/261826-1.xul.

In this test, the <tab> elements seem to be larger in Stylo than in Gecko. Using inspector, it seems that the <hbox> inside the binding of <tab> is incorrectly sized to be larger than its content for no reason.

Need some more investigation.
It seems there are several reftests showing the same symptom.
It seems <gridlikeheader> has a similar issue, seen in layout/reftests/bugs/374719-1.xul. Not sure whether they are the same issue but I'm going to mark them the same for now.
Somehow XUL <button> element in reftests/native-theme/676387-1.xul also has a larger height in Servo than in Gecko. Maybe related as well.
Summary: stylo: <tab> element is sized incorrectly → stylo: various XUL elements are sized incorrectly
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1408811
You need to log in before you can comment on or make changes to this bug.