Can't paste bookmarked websites into folders

RESOLVED WONTFIX

Status

()

P3
normal
RESOLVED WONTFIX
a year ago
9 months ago

People

(Reporter: valentina.ona, Unassigned)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(firefox56 affected, firefox57 affected, firefox58 affected)

Details

(Whiteboard: [fxsearch])

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8918863 [details]
bookmarks.webm

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID 20171015220106

[Affected Platforms]: Windows 7 x64, Windows 10 x64, Mac OS X 10.12

[Affected platforms]: Nightly 58.0a1, Firefox Release 56.0

[Steps to reproduce];

1. Launch Nightly 58.0a1
2. Enable the Menu Bar
3. Open Bookmarks and create a new folder
4. Navigate to a page, bookmark it and save in the folder that was created
5. Open another page and bookmark it on the "other bookmarks" folder
6. Copy the latest bookmarked page and go to the first folder and click right button and paste it.

[Expected results]: The page should be pasted into the folder

[Actual Results]: The page is pasted outside the folder.

[Note]: This issue appears on the "show your bookmarks" and "menu bar bookmarks"

For more information please see the attachment.
I tested this on Mac using the bookmarks toolbar. When pasting I sometimes see:

ReferenceError: reference to undefined property "dropNearNode"  controller.js:49:1

It doesn't seem to be a regression, goes back to at least 50 (I wouldn't be surprised if it was like that from the start).
Priority: -- → P3
Whiteboard: [fxsearch]
Now I look at this again, I think this is intentional - if right clicking on the folder name pasted it into the folder, then you wouldn't be able to paste something into the middle of a list of folders.

Marco, what do you think?
Flags: needinfo?(mak77)
Yes, there are 2 possible behaviors for insertionPoint we can pick:
1. insert-into
2. insert-before

We are not completely consistent on the default behavior.
On menus and toolbar we insert-before by default, because otherwise you could not insert anything between 2 folders. On the other side these views provide empty menus where you can insert-into. This way both actions are supported.

In the trees there is no concept of an empty leaf and thus we insert-into by default. If we'd insert-before instead, you'd never be able to insert into an empty folder. On the other side this means on trees you can't insert anything between 2 folders in trees.

It's a compromise, I'm open to suggestions on how to solve it, but so far it's by design due to the above limitations.
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Flags: needinfo?(mak77)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.