Closed Bug 1409043 Opened 5 years ago Closed 8 months ago

[Linux] Onboarding tour highlight is faulty

Categories

(Firefox :: Tours, defect, P3)

All
Linux
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox56 --- unaffected
firefox57 --- affected
firefox58 --- affected

People

(Reporter: ccomorasu, Unassigned)

References

Details

(Keywords: regression, Whiteboard: QA-not-reproducible, [photon-onboarding])

Attachments

(2 files, 2 obsolete files)

[Affected versions]:
 Fx 57.0b8
 Fx 58.0a1

[Affected platforms]:
 Ubuntu 14.04 LTS x64
 Ubuntu 16.04 LTS x86

[Steps to reproduce]:
 1. Launch Firefox with a clean profile.
 2. Open a new tab.
 3. Click on the fox logo to start the tour.
 4. Click on one of the new items and select "Show..." button.

[Expected result]:
 The browser highlights the new item accordingly.

[Actual result]:
 The browser's highlight is faulty.

[Regression range]:
 I will return with the Regression Range as soon as possible.

[Additional notes]:
 a. Screen shot with the issue on beta: https://imgur.com/a/YTiIV
 b. Screen Shot with the issue on nightly: https://imgur.com/a/2I6iU
Has Regression Range: --- → yes
Has STR: --- → yes
Priority: P1 → P3
Has Regression Range: yes → no
Attached image normal (obsolete) —
can't reproduce on Ubuntu 16.04.2 LTS with nightly (build from today's source)
Attached image normal (obsolete) —
sorry upload the wrong screenshot
Attachment #8919581 - Attachment is obsolete: true
Attached image normal
Attachment #8919583 - Attachment is obsolete: true
Are you using an unbranded version of the browser? I am asking because the logo is different.
Flags: needinfo?(gasolin)
yes it's built from source code
Flags: needinfo?(gasolin)
Can you please try with a latest beta/nightly?
Hi Ritu,

I believe this is a blocker for 57. Can you please help us assess the bug and mark accordingly?
Flags: needinfo?(rkothari)
Spoke with Ritu yesterday over slack.

She said that we don't know if this is a real problem yet and linux bugs are non-blockers.
Today during release coordination meeting, Julien mentioned that this should be a blocker.
I'll let Ritu chime in for final call.
I can confirm this issue is not reproducible on some machines. I noticed the Accessibility Features Enabled icon on the machines that reproduce this issue; I disabled it from about:preferences, but the issue is still reproducible.

Below are the results from mozregression:

 6:44.83 INFO: Narrowed inbound regression window from [5a63d845, 3d72fdb0] (4 builds) to [5a63d845, 14db7c0b] (2 builds) (~1 steps left)
 6:44.83 INFO: No more inbound revisions, bisection finished.
 6:44.83 INFO: Last good revision: 5a63d8457a2a69a2ad54a50765bff412580df2a4
 6:44.83 INFO: First bad revision: 14db7c0bcf9ae86c9ec2cc9d3c249a42e459a2a9
 6:44.83 INFO: Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5a63d8457a2a69a2ad54a50765bff412580df2a4&tochange=14db7c0bcf9ae86c9ec2cc9d3c249a42e459a2a9
Has Regression Range: no → yes
This may be a real problem. I would not call it a blocker just yet. 

Hi Selena, could you please help find a change in the pushlog that could be blamed for this regression? I wasn't able to tell even though I looked over that pushlog twice.
Flags: needinfo?(rkothari) → needinfo?(sdeckelmann)
Maybe bug 1383501? NI'ing jim. (see comment 9)
Flags: needinfo?(sdeckelmann) → needinfo?(jmathies)
For the record I don't think this should block also, given it does not reproduce on every Linux distro.
(In reply to Selena Deckelmann :selenamarie :selena use ni? pronoun: she from comment #11)
> Maybe bug 1383501? NI'ing jim. (see comment 9)

Not caused by that, I don't think accessibility is at play here. Sounds like a native theme bug or something with GTK. Reporter, can you provide information on your desktop environment?
Flags: needinfo?(jmathies)
Sorry for the long pause.

The environment has the following specs:
OS: ubuntu 14.04 LTS 
Memory: 7,7 GiB
Processor: Intel Core i5-5200U CPU 2.20 GHz x 4
Graphics: Intel HD Graphics 5500
OS type: 64 bit

PS: I could reproduce it using Fx 57.0b12. If I can help any further please needinfo me.
Flags: needinfo?(jmathies)
(In reply to Cristian Comorasu [:CristiComo] from comment #14)
> Sorry for the long pause.
> 
> The environment has the following specs:
> OS: ubuntu 14.04 LTS 
> Memory: 7,7 GiB
> Processor: Intel Core i5-5200U CPU 2.20 GHz x 4
> Graphics: Intel HD Graphics 5500
> OS type: 64 bit
> 
> PS: I could reproduce it using Fx 57.0b12. If I can help any further please
> needinfo me.

the mozilla build or a local build of the beta 12 source? So far we've only received a report of this happening in a local build. If this happens in release builds that's new.
Flags: needinfo?(cristian.comorasu)
I took the builds from the Mozilla Archives( https://archive.mozilla.org/pub/devedition/candidates/ ). I retested with 57 beta 3, 4, 5, 6, 7, 8, 9, 10, 11, 12 and 13. I could reproduce it with all of them. 
The a11y icon was present on the tab bar, on the machine that does not reproduce this issue the icon is not displayed.

Can I provide more info?
Flags: needinfo?(cristian.comorasu)
(In reply to Cristian Comorasu [:CristiComo] from comment #16)
> I took the builds from the Mozilla Archives(
> https://archive.mozilla.org/pub/devedition/candidates/ ). I retested with 57
> beta 3, 4, 5, 6, 7, 8, 9, 10, 11, 12 and 13. I could reproduce it with all
> of them. 
> The a11y icon was present on the tab bar, on the machine that does not
> reproduce this issue the icon is not displayed.
> 
> Can I provide more info?

If you force disable accessible services support through preferences and restart, does the problem go away?

Also, I'm not familiar with accessibility clients on linux, do you know what a11y client you're running?
Flags: needinfo?(jmathies) → needinfo?(cristian.comorasu)
It seemed like a coincidence, as I disabled all of the prefs and it is still reproducible. No other a11y programs were running in the background.
PS: as far as I know that icon is disabled for beta now.
Flags: needinfo?(cristian.comorasu)
Please post your about:support text.
Flags: needinfo?(cristian.comorasu)
This is the about:support from a clean profile that reproduces this issue.
Flags: needinfo?(cristian.comorasu)

Hello! I have tried to reproduce the issue with firefox 96.0a1(2021-11-15), 95.0b7 and 94.0.1 on with Ubuntu 20, unfortunately I wasn't able to reproduce the issue.

Marking this issue as RESOLVED->WORKSFORME, if the issue is still valid please feel free to reopen this issue.

Thank you!

Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → WORKSFORME
Whiteboard: [photon-onboarding] → QA-not-reproducible, [photon-onboarding]
You need to log in before you can comment on or make changes to this bug.