Closed Bug 1409048 Opened 3 years ago Closed 3 years ago

2.4% build times (windows2012-32) regression on push b4c54a5506af769e0d94a4ae2eb6e82642284dc3 (Thu Oct 12 2017)

Categories

(Firefox Build System :: General, defect)

53 Branch
defect
Not set
normal

Tracking

(firefox56 unaffected, firefox57 unaffected, firefox58 fixed)

RESOLVED DUPLICATE of bug 1408836
Tracking Status
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- fixed

People

(Reporter: jmaher, Unassigned)

References

Details

(Keywords: regression)

We have detected a build metrics regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=b4c54a5506af769e0d94a4ae2eb6e82642284dc3

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

  2%  build times summary windows2012-32 opt static-analysis taskcluster-c4.4xlarge     2,481.56 -> 2,541.04


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=9986

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Automated_Performance_Testing_and_Sheriffing/Build_Metrics
I am not able to easily determine where this regression took place at, but you can see it on the graph:
https://treeherder.mozilla.org/perf.html#/graphs?timerange=1209600&series=%5Bautoland,e35f2f71dbb7dcbcc843a1e272e94d2e52727bf9,1%5D&selected=%5Bautoland,e35f2f71dbb7dcbcc843a1e272e94d2e52727bf9%5D

:ted, can you pick up this bug and/or find the right person to look at it?
Component: Untriaged → Build Config
Flags: needinfo?(ted)
Product: Firefox → Core
I checked the sccache hit rate graph for those builds and it doesn't look like that has meaningfully changed:
https://treeherder.mozilla.org/perf.html#/graphs?series=autoland,1530957,1,2&zoom=1507853088990.5437,1508088809293.1443,0,0.9701492537313433

Clicking on one of the changesets from the beginning of the high part of the graph showed:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=ab68cb44bb45aa73f0fa0a1eefe33430041b9872&tochange=169bde8f9f3c5fd07e7de900552fa544a62f1906

which is a merge containing bug 1408211, which is very plausible.
Flags: needinfo?(ted)
Blocks: 1408836
No longer blocks: 1408836
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1408836
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.