Closed Bug 1409220 Opened 2 years ago Closed 8 months ago

Move mPubKeyCredParams processing to U2FTokenManager

Categories

(Core :: DOM: Device Interfaces, enhancement, P2)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1522145
Future
Tracking Status
firefox57 --- unaffected

People

(Reporter: jcj, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [webauthn] [webauthn-cleanup])

WebAuthnManager's MakeCredential method takes parameters describing what kind of keys the RP would like to use -- P-256 curve keys from FIDO U2F, for example, or maybe only something newer from CTAP.

WebAuthnManager doesn't know enough to filter this information, so we need to move the "for Options.mPubKeyCredParams" logic down into the U2FTokenManager where it knows enough to only accept U2F-capable parameters.
Unblocking WD-07 on this; it's not critical.
No longer blocks: 1384776
Priority: P1 → P2
See Also: → 1522145
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1522145
You need to log in before you can comment on or make changes to this bug.