there is a CubebAggregateDevice in device list , there is a "NotReadableError" if select the device

RESOLVED DUPLICATE of bug 1404971

Status

()

Core
WebRTC: Audio/Video
RESOLVED DUPLICATE of bug 1404971
a month ago
a month ago

People

(Reporter: xpeng, Unassigned, NeedInfo)

Tracking

56 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a month ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170926190823

Steps to reproduce:

1.use the demo to select device in macbook
https://webrtc.github.io/samples/src/content/devices/input-output/
there is a new device CubebAggregateDevice_XXXXXXX in device list 
2. select the CubebAggregateDevice_XXXXXXX to getusermedia.


Actual results:

1. there is a error : NotReadableError


Expected results:

there is no error if the device is available

Updated

a month ago
Component: Untriaged → WebRTC: Audio/Video
Product: Firefox → Core
Did the Firefox crash before you have the extra device in the list?
Flags: needinfo?(xpeng)
Status: UNCONFIRMED → RESOLVED
Last Resolved: a month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1404971
You need to log in before you can comment on or make changes to this bug.