Closed Bug 1409271 Opened 2 years ago Closed 2 years ago

<a><img srcset></a> is too wide at developer.microsoft.com

Categories

(Core :: Layout, defect, P3)

57 Branch
Unspecified
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1149357

People

(Reporter: bmo, Unassigned)

References

()

Details

(Whiteboard: [webcompat])

Attachments

(1 file)

There is a a tag on the Chrome, Firefox and Safari images.

Thoses a tags take more width than they should, indeed there initial display value is "block", instead of "contents".

With diplay: contents the problem is fixed.

Thanks.
[![Screenshot Description](https://webcompat.com/uploads/2017/10/de11b285-b801-4957-8a21-0efc4200ed94-thumb.jpg)](https://webcompat.com/uploads/2017/10/de11b285-b801-4957-8a21-0efc4200ed94.jpg)
This is bug 1404056 per dholbert's comment on webcompat.com.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1404056
Clearing confusing bug-summary.  As noted in https://github.com/webcompat/web-bugs/issues/12339#issuecomment-337308065 , we're handling `display` values correctly here - that property is not involved in the rendering problem, as far as I can tell.
Summary: The a TAG is displaying as block instead of contents → <a><img srcset></a> is too wide at developer.microsoft.com
(And turns out the underlying dupe was filed longer ago as bug 1149357 -- updating dupe-target to that.)
Duplicate of bug: 1149357
You need to log in before you can comment on or make changes to this bug.