Closed Bug 1409283 (build-gcc-8) Opened 2 years ago Closed 18 days ago

[meta] Build with gcc 8

Categories

(Firefox Build System :: Source Code Analysis, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Sylvestre, Unassigned)

References

(Depends on 5 open bugs)

Details

(Keywords: meta)

Using Debian snapshot packages available here:
https://tracker.debian.org/pkg/gcc-8
Depends on: 1409284
Depends on: 1409285
Depends on: 1409326
Depends on: 1409382
Depends on: 1410379
Depends on: 1411027
Depends on: 1411034
Depends on: 1411037
Depends on: 1411049
Depends on: 1411056
Depends on: 1411545
No longer depends on: 1411545
Depends on: class-memaccess
Depends on: 1424866
Depends on: 1424867
Depends on: 1426997
Depends on: 1430729
Depends on: 1431109
Depends on: 1435223
Depends on: 1435262
Depends on: 1437482
Depends on: 1437877
Depends on: 1438196
Product: Core → Firefox Build System
Depends on: 1447480
Depends on: 1461614
Depends on: 1472471
Depends on: 1472569
See Also: → build-clang-trunk
Depends on: 1474183
Depends on: 1474185
Depends on: 1477540
Depends on: 1482792
Severity: normal → enhancement
Keywords: meta
See Also: → build-gcc-9
Barror has a list of new warning flags introduced in each new version of clang and gcc. Here are the new warning flags in gcc 8:

https://github.com/Barro/compiler-warnings/blob/master/gcc/warnings-gcc-diff-7-8.txt

-Wattribute-alias
-Wcast-align=strict
-Wcast-function-type
-Wcatch-value (enabled by -Wall)
-Wcatch-value=3
-Wclass-memaccess (enabled by -Wall)
-Wextra-semi
-Wif-not-aligned
-Wmissing-attributes (enabled by -Wall)
-Wmultistatement-macros (enabled by -Wall, disabled by bug 1411037)
-Wpacked-not-aligned (enabled by -Wall)
-Wsizeof-pointer-div (enabled by -Wall)
-Wstringop-truncation (enabled by -Wall)
-Wsuggest-attribute=cold
-Wsuggest-attribute=malloc
Duplicate of this bug: 1455279
Depends on: 1516758
No longer depends on: 1516758
Depends on: 1517350
Depends on: 1434070, 1544881, 1531748
See Also: → 1493532
Depends on: 1558054
Depends on: 1571292

bug 1514781 is now the place to be

Status: NEW → RESOLVED
Closed: 18 days ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.